summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-02-11 12:47:57 +0200
committerMart Raudsepp <leio@gentoo.org>2017-02-11 16:52:20 +0200
commitf3f73c6df02a72b912e5fd16000f5321bf70246c (patch)
treeb6fdb241ad9cd21b16258040b350beb39afd3fee /dev-python/gst-python
parentmedia-plugins/gst-plugins-x265: bump to 1.10.3 (diff)
downloadgentoo-f3f73c6df02a72b912e5fd16000f5321bf70246c.tar.gz
gentoo-f3f73c6df02a72b912e5fd16000f5321bf70246c.tar.bz2
gentoo-f3f73c6df02a72b912e5fd16000f5321bf70246c.zip
dev-python/gst-python: bump to 1.10.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest1
-rw-r--r--dev-python/gst-python/gst-python-1.10.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index 8c8cee80d6ba..7f79a3689230 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1,2 +1,3 @@
DIST gst-python-0.10.22.tar.bz2 632651 SHA256 8f26f519a5bccd770864317e098e5e307fc5ad1201eb96329634b6508b253178 SHA512 bbbd6b661778cca990da0e216294d86da31a6e472049905989a3311459dd1227bf8f2ae3699a3cdbb66a16288569764352f1e1b93e696d3db4b0728bc38e5b12 WHIRLPOOL c6902554bc8f390b5d295d05598ee60fd6b2637d290125d83a48fc40bbd4e6e261a711430259831c96a30fee4c5ec5c89aea444424b117fb5d62c946b0263454
+DIST gst-python-1.10.3.tar.xz 389748 SHA256 bdfa2d06dfe0ce68f638b04fed6890db506416c1dcf1279e83458269d719a4e8 SHA512 346fae905f5d0d3e6295c4752351e629871e9373f2bf7e1acff0778f0935f81dd6043ae0d9ae774919a19ad8bd19bd9ea3456a3a1a381c9e63e5ad2ee5bf1530 WHIRLPOOL 4540cc8bda15dd4a4b07bf67d440c42c41b4165b92e417abcfc3f84495c7ca712621976dd3db9ce7589ef6fa691afefbefbfe407ef765e888a06dc0a6733d842
DIST gst-python-1.8.3.tar.xz 370524 SHA256 149e7b9c2c361832bc765d39bce004d1ffe1b330c09c42dc902ca48867e804ce SHA512 1660123c7ab8db85ee617fc2cd67fef4abac33e8fe1dc4d9e98b70612bb0bc6e9ea98702139f007c3e26d0139d655d6b43bcbc2cc9fade4156e6ee4842cd4119 WHIRLPOOL 432f67b6d224ed66b6601264a98a841e02c2c2d119cbb26f22d55b5b72f98fc2bcaaa833ed19b7251f928e7f7936888ff57251985fb87a1ffd3c887071803db9
diff --git a/dev-python/gst-python/gst-python-1.10.3.ebuild b/dev-python/gst-python/gst-python-1.10.3.ebuild
new file mode 100644
index 000000000000..c8cff089efce
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.10.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
+
+inherit eutils python-r1
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ prepare_gst() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_gst
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ prune_libtool_files --modules
+ einstalldocs
+}