summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-31 15:56:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-31 16:49:52 +0100
commit31b265a31b3bbb4961474d46af4e140cded5d3b7 (patch)
tree7cbf5d798374476b7100b490b415f3feea848dba /dev-python/google-api-python-client
parentdev-python/async-timeout: Bump to 5.0.0 (diff)
downloadgentoo-31b265a31b3bbb4961474d46af4e140cded5d3b7.tar.gz
gentoo-31b265a31b3bbb4961474d46af4e140cded5d3b7.tar.bz2
gentoo-31b265a31b3bbb4961474d46af4e140cded5d3b7.zip
dev-python/google-api-python-client: Bump to 2.151.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.151.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 4ba06972876a..d484799b42aa 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1 +1,2 @@
DIST google_api_python_client-2.149.0.tar.gz 11791789 BLAKE2B b4397d1e0a6b064b9c7aa7b4ada816a76871de089776f6aab4cc1f962171a427ecd1e4c1ba9e43455becaddd31cfa50082aa498a1443d2116f0acb678d221549 SHA512 3602a9d5f9fd5e00605a2b12114a81770662ac1ad168c65160d6c64340d8ea3f3da2765a5cc5959ef09f5b72725baa493a0686d976e3d22add49bb86b21626e7
+DIST google_api_python_client-2.151.0.tar.gz 12030480 BLAKE2B afbe2cb25e789aaa1aa5cf94e0b2a8e910cb097a885d6dc479af27e7836ac96a2a3db7b54b3fe5e060bdd4c0bdfa86dab3f0cab2e0ea176a6802d455ec7eda77 SHA512 3a8f55f457106779798e0bdf544c9bb9482967dcf0329a9a85f390a4acf8b9946ee56e43af798966c0958ae934426081bbf29cbb344071f2589b84937e85ed37
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.151.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.151.0.ebuild
new file mode 100644
index 000000000000..58a0eb467bad
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.151.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}