summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 17:31:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 17:37:52 +0200
commited04d1f4a5c4bdd56dd94d26d749bfb6fcbebdc3 (patch)
tree068baea1af0d7af49b41569340ea3b942bfaf04f /dev-python/future/future-0.18.2-r1.ebuild
parentdev-python/funcsigs: Remove python2 (diff)
downloadgentoo-ed04d1f4a5c4bdd56dd94d26d749bfb6fcbebdc3.tar.gz
gentoo-ed04d1f4a5c4bdd56dd94d26d749bfb6fcbebdc3.tar.bz2
gentoo-ed04d1f4a5c4bdd56dd94d26d749bfb6fcbebdc3.zip
dev-python/future: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/future/future-0.18.2-r1.ebuild')
-rw-r--r--dev-python/future/future-0.18.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/future/future-0.18.2-r1.ebuild b/dev-python/future/future-0.18.2-r1.ebuild
new file mode 100644
index 000000000000..eb37d44dc5c1
--- /dev/null
+++ b/dev-python/future/future-0.18.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
+HOMEPAGE="https://python-future.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# TODO: restore numpy when python2.7 is gone
+#BDEPEND="test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-bootstrap-theme
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tests.patch
+ "${FILESDIR}"/${P}-py39.patch
+)
+
+python_prepare_all() {
+ # tests requiring network access
+ rm tests/test_future/test_requests.py || die
+ sed -i -e 's:test.*request_http:_&:' \
+ tests/test_future/test_standard_library.py || die
+
+ distutils-r1_python_prepare_all
+}