summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-12 16:31:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-12 16:31:19 +0100
commite86af5b220ef25f3abd301ff2124122c49159402 (patch)
tree6a7f29623d5bb9b96771eb35128c38711e9edcf1 /dev-python/flask-paginate
parentpackage.mask: Last rite sci-chemistry/molscript (diff)
downloadgentoo-e86af5b220ef25f3abd301ff2124122c49159402.tar.gz
gentoo-e86af5b220ef25f3abd301ff2124122c49159402.tar.bz2
gentoo-e86af5b220ef25f3abd301ff2124122c49159402.zip
dev-python/flask-paginate: Bump to 2022.1.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-2022.1.8.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index f8a8abdd5e85..45124a8d93f0 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1,2 +1,3 @@
DIST flask-paginate-2021.10.26.tar.gz 120721 BLAKE2B dd37fa131baf20540620c350bca4a17f791df57c82fabd99e644891707259d330d4225fc666d3e5c31410bc17e10531bf735ab8a01e7129641fa81a9d8fbfe82 SHA512 86a782797a9401eecbbfc25c90834ed93d7c376c3eb6bc05f19edf7ad6f174aca01de9dc3b183c0c268e2995d81984fa1568e08aae8964e429c60f01b7b23736
DIST flask-paginate-2021.12.28.tar.gz 120846 BLAKE2B 63c14a94db4c968ef22a84b28aee2ca3e223fa0a7a32e22644b02b718ae32ea9ece9177b85c66942165e01926b26bb599dd3ae47522ba9bbf9a1c68b7a5ce567 SHA512 3ff805ad2d30aadfd1affabde0b0caccf2c3c2efb54b0997f809e13a76c6db64082d0f003ba4485a824e48d5d2792d99bab5173059ebe5a4077a1aac99b3c4ca
+DIST flask-paginate-2022.1.8.tar.gz 120847 BLAKE2B 110d6f7bb6c244378a41ab26c914898b54fb05cc00cfc6c7c3e15ed96e2163f92cc89c4ce93199091d8ed2f52301e997ebc16a71a3d802b8107249f9f832ca25 SHA512 9f2e0e50d73ac15ec2a413671a52e9dbbbb7eac8576494483441ea1287a12e2076cf649ee9df0bf3b3d2c7e13eebe4a835031ab57a2e8b2015f383d53318a0b9
diff --git a/dev-python/flask-paginate/flask-paginate-2022.1.8.ebuild b/dev-python/flask-paginate/flask-paginate-2022.1.8.ebuild
new file mode 100644
index 000000000000..186458c0798f
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2022.1.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}