summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-20 18:23:36 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-20 19:55:25 +0200
commit7c4fa0f6cf1e2441455f212430c4a6ad6bec9eec (patch)
treef942d40b809858dcf29650eb47f1c6ae4e866ec0 /dev-python/flask-nav
parentapp-portage/pycargoebuild: Bump to 0.6.2 (diff)
downloadgentoo-7c4fa0f6cf1e2441455f212430c4a6ad6bec9eec.tar.gz
gentoo-7c4fa0f6cf1e2441455f212430c4a6ad6bec9eec.tar.bz2
gentoo-7c4fa0f6cf1e2441455f212430c4a6ad6bec9eec.zip
dev-python/flask-nav: PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask-nav')
-rw-r--r--dev-python/flask-nav/Manifest1
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/flask-nav/Manifest b/dev-python/flask-nav/Manifest
index 9b9e51c62b38..5140bb5c30e2 100644
--- a/dev-python/flask-nav/Manifest
+++ b/dev-python/flask-nav/Manifest
@@ -1 +1,2 @@
+DIST flask-nav-0.6.gh.tar.gz 12270 BLAKE2B eff90b6fc08629139012e2d920b4d464ed06954040a5e97636a7aa4d59d11654839460ef52477cfcec967bd774d942028a53675d682e850f08f6359c5cfbb54e SHA512 a7930687425a53fac9ad9a7cb65c2e2a759a0c9660189965bf37ea6e9925dd869074d37a283801631b3e6c3391f9f4167e0a36294104f72970e876b5a7a0930c
DIST flask-nav-0.6.tar.gz 12270 BLAKE2B eff90b6fc08629139012e2d920b4d464ed06954040a5e97636a7aa4d59d11654839460ef52477cfcec967bd774d942028a53675d682e850f08f6359c5cfbb54e SHA512 a7930687425a53fac9ad9a7cb65c2e2a759a0c9660189965bf37ea6e9925dd869074d37a283801631b3e6c3391f9f4167e0a36294104f72970e876b5a7a0930c
diff --git a/dev-python/flask-nav/flask-nav-0.6-r5.ebuild b/dev-python/flask-nav/flask-nav-0.6-r5.ebuild
new file mode 100644
index 000000000000..216651283ff5
--- /dev/null
+++ b/dev-python/flask-nav/flask-nav-0.6-r5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create navigation for Flask applications"
+HOMEPAGE="https://pythonhosted.org/flask-nav/"
+# docs are missing from PyPI tarballs
+# https://github.com/mbr/flask-nav/pull/12
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster
+
+PATCHES=(
+ # https://github.com/mbr/flask-nav/pull/27
+ "${FILESDIR}/${P}-py310.patch"
+)