summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 14:10:49 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 15:11:07 +0200
commit3aec1c58e64e834cb7d3f1b268d1f3c398970abc (patch)
tree44444a85f6b808269ca2a3e3907753387f3dc475 /dev-python/flask-mail/flask-mail-0.9.0.ebuild
parentdev-python/flask-login: Clean old versions up (diff)
downloadgentoo-3aec1c58e64e834cb7d3f1b268d1f3c398970abc.tar.gz
gentoo-3aec1c58e64e834cb7d3f1b268d1f3c398970abc.tar.bz2
gentoo-3aec1c58e64e834cb7d3f1b268d1f3c398970abc.zip
dev-python/flask-mail: Clean old versions up
Diffstat (limited to 'dev-python/flask-mail/flask-mail-0.9.0.ebuild')
-rw-r--r--dev-python/flask-mail/flask-mail-0.9.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/flask-mail/flask-mail-0.9.0.ebuild b/dev-python/flask-mail/flask-mail-0.9.0.ebuild
deleted file mode 100644
index e71a1e15f741..000000000000
--- a/dev-python/flask-mail/flask-mail-0.9.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Mail"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flask extension for sending email"
-HOMEPAGE="http://pythonhosted.org/Flask-Mail/ https://pypi.python.org/pypi/Flask-Mail"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}