summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/extremes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/extremes')
-rw-r--r--dev-python/extremes/Manifest1
-rw-r--r--dev-python/extremes/extremes-1.1.1.ebuild29
-rw-r--r--dev-python/extremes/metadata.xml8
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/extremes/Manifest b/dev-python/extremes/Manifest
new file mode 100644
index 000000000000..6b26d634b3f2
--- /dev/null
+++ b/dev-python/extremes/Manifest
@@ -0,0 +1 @@
+DIST extremes-1.1.1.zip 10360 SHA256 e92564d2535929a18c51b75c8904e13ab5e78a6d75fee8c70d04e09812fc8545 SHA512 a0b951306e9d5ef84c6498268a3476e7ed889f0be950a529774e2d8c4f155d4c10cbacd20864ed37aea5512ba65a267e414eb2b4f7cc6d67b21a020d82da8ec2 WHIRLPOOL 67a3a7aa5b4f32497f262097d34ac750f34a89471290f7eb7b9a3a3491f36bc08e6db0341f852ca3f575767dc21a9b8d4f97a9f0d7ce68559eb2cb6564d51a55
diff --git a/dev-python/extremes/extremes-1.1.1.ebuild b/dev-python/extremes/extremes-1.1.1.ebuild
new file mode 100644
index 000000000000..444ed101a605
--- /dev/null
+++ b/dev-python/extremes/extremes-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="Extremes"
+DESCRIPTION="Production-quality 'Min' and 'Max' objects"
+HOMEPAGE="http://pypi.python.org/pypi/Extremes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip -> ${P}.zip"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+LICENSE="ZPL"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+python_test() {
+ "${PYTHON}" peak/util/extremes.py && einfo "Tests passed under ${EPYTHON}" \
+ || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/extremes/metadata.xml b/dev-python/extremes/metadata.xml
new file mode 100644
index 000000000000..dbb8c8452512
--- /dev/null
+++ b/dev-python/extremes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Extremes</remote-id>
+ </upstream>
+</pkgmetadata>