summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-14 18:35:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-14 18:54:45 +0200
commit55f4769b9c3c774c38183f80bd50abf0f1319678 (patch)
tree9e9e65d3783c02902af4f55d08822a109e84863e /dev-python/execnet
parentnet-fs/cifs-utils: Stabilize 7.0-r1 ppc64, #941475 (diff)
downloadgentoo-55f4769b9c3c774c38183f80bd50abf0f1319678.tar.gz
gentoo-55f4769b9c3c774c38183f80bd50abf0f1319678.tar.bz2
gentoo-55f4769b9c3c774c38183f80bd50abf0f1319678.zip
dev-python/execnet: Enable py3.13t
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/execnet-2.1.1.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/execnet/execnet-2.1.1.ebuild b/dev-python/execnet/execnet-2.1.1.ebuild
index 24aaa101f1b2..24024951426a 100644
--- a/dev-python/execnet/execnet-2.1.1.ebuild
+++ b/dev-python/execnet/execnet-2.1.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} python3_13t pypy3 )
inherit distutils-r1 pypi
@@ -27,6 +27,17 @@ distutils_enable_sphinx doc
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ python3.13t)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pytest-dev/execnet/issues/306
+ testing/test_channel.py::TestChannelBasicBehaviour::test_channel_callback_remote_freed
+ )
+ ;;
+ esac
+
# the test suite checks if bytecode writing can be disabled/enabled
local -x PYTHONDONTWRITEBYTECODE=
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1