summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 23:27:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 23:35:13 +0100
commitde316e21731e52c8c20d987869e69915c4feb4b8 (patch)
treec7a3862e91a521016df74932bec565baf901eda9 /dev-python/et_xmlfile
parentx11-wm/icewm: Removed old (diff)
downloadgentoo-de316e21731e52c8c20d987869e69915c4feb4b8.tar.gz
gentoo-de316e21731e52c8c20d987869e69915c4feb4b8.tar.bz2
gentoo-de316e21731e52c8c20d987869e69915c4feb4b8.zip
dev-python/et_xmlfile: Switch to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/et_xmlfile')
-rw-r--r--dev-python/et_xmlfile/et_xmlfile-1.1.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/et_xmlfile/et_xmlfile-1.1.0-r1.ebuild b/dev-python/et_xmlfile/et_xmlfile-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..dbfbac7ecd70
--- /dev/null
+++ b/dev-python/et_xmlfile/et_xmlfile-1.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PV=${PV%.0}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="An implementation of lxml.xmlfile for the standard library"
+HOMEPAGE="
+ https://pypi.org/project/et-xmlfile/
+ https://foss.heptapod.net/openpyxl/et_xmlfile/"
+SRC_URI="
+ https://foss.heptapod.net/openpyxl/et_xmlfile/-/archive/${MY_PV}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc