summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-26 21:38:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-26 21:42:40 +0300
commit227f255df07c4bb277b9a9d8f5d52cbb2e39b888 (patch)
tree4b00e0b3edeb02043710520527688bc2d7676234 /dev-python/dns-lexicon
parentdev-python/cx_Freeze: add 6.13.0 (diff)
downloadgentoo-227f255df07c4bb277b9a9d8f5d52cbb2e39b888.tar.gz
gentoo-227f255df07c4bb277b9a9d8f5d52cbb2e39b888.tar.bz2
gentoo-227f255df07c4bb277b9a9d8f5d52cbb2e39b888.zip
dev-python/dns-lexicon: add 3.11.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest1
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index dc5a82ca4ecb..b3cee1cc1423 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,3 +1,4 @@
DIST dns-lexicon-3.11.4.gh.tar.gz 8429864 BLAKE2B 552c87427fc04683e3e6b540fa3e62f88628f833b8229d52dde9f53d77c1cc32968aa9b0c3d04876145067950752c8fb68c1540cee82cf5687bc16d26d7ebd63 SHA512 d7c1f085ffcb4589430f744970bbc6793779fb19d4cc29b071937d768cb271330794fccf38b60a82ed6362dda4101ac6643704bb703df242c8f2a17273dc6fbe
DIST dns-lexicon-3.11.5.gh.tar.gz 8428184 BLAKE2B 061786f9a198e078b07a6c57db36310f71043509aa5fb640a4733373ab874091805d51eea2dd543b77e7f6c3f05239bfe0a6ff0cd4753ab6f1342ebe204059e3 SHA512 c7db28587aefe05fd0704556852240a8e9c79668bcadf873adfe9ff81666bff2c9ebebc56730fa767d91c9b58de44da8834e0b2af93aeaff53ef55d3b3439105
DIST dns-lexicon-3.11.6.gh.tar.gz 8428294 BLAKE2B dcbf2cc22d09c9f54378c4b1a29dcfa4d3b4d4c157b1f90ec9b78c62b4a0ea03c82484ed2825e5f6e9988dcc18da3be1a89458734ef2c7e90077c3139e44179f SHA512 086aa7daeef176960e058d60495f748c6c2acaf065801e41fe4b77c1bb44c8fd98b13805d9dc393d9be20d4e2d12ebc0967a0e07ec561fa4c33666a8f6e7ab18
+DIST dns-lexicon-3.11.7.gh.tar.gz 6677647 BLAKE2B 9330bcc81e053e9cf8b2171b444e5d20e86922da15df7121a5957f8e6932528ba1f9099cc4dff08b2825d8fa253369b8b2da026a0846e64896bf491c59f2bdc9 SHA512 7d3becea6b9d60a4589e9d7e8de010d0b7e6a2c127d1ccc6981d1bff88d09f5a708fd3e9e22f66b8a0a77a331784340662de73607dd25d69c0342795c6afc765
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild
new file mode 100644
index 000000000000..c6c99ff85a56
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+ # All recordings seem to be broken
+ lexicon/tests/providers/test_namecheap.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}