summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-01-26 13:56:11 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-26 13:56:11 -0600
commit0f23fad3104733da6d491c611a45aeb812e89b41 (patch)
treef9411e93800f2098ffa960c394c01f837036da8f /dev-python/django-auth-ldap
parentdev-python/virtualenv: Regen Manifest (diff)
downloadgentoo-0f23fad3104733da6d491c611a45aeb812e89b41.tar.gz
gentoo-0f23fad3104733da6d491c611a45aeb812e89b41.tar.bz2
gentoo-0f23fad3104733da6d491c611a45aeb812e89b41.zip
dev-python/django-auth-ldap: 2.1.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest1
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 2782051a1800..9fdb457b4368 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1 +1,2 @@
DIST django-auth-ldap-1.7.0.tar.gz 48897 BLAKE2B b4b196e4cd0882a48d2437326cda57394963fa44a64a3cf5a0ff668bb86243da3979e2746e096a458a5bf1d3c8be687f3d3fe456f5a6b0ada11ebd1f4787e323 SHA512 6478b2ef43e6f49acff3dd2e3a2a462ae02a3f1475d5615ba2f14bfd5efe2b232a3d2008902177d90822fea6b096a05814a5f028f4eec5ee09c5e5a62793e73d
+DIST django-auth-ldap-2.1.0.tar.gz 51027 BLAKE2B 1229d184746cf05f9c7ddb9e6674b2c529a0fc6d051f78ba01de6a80b0e5e408a8da10e35087efad60f1fef90be708e8a0c05b04c4408500329d9dfb567c0f8b SHA512 4c204eee856e33fae80a22a80bd0f3a21d1f2ee33b1ad56087832f89e91d7e1441579cf77541c1c35e8e0532d4da937b736fe3b4708d7c2d7bbccacbb0b24061
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild
new file mode 100644
index 000000000000..2dcefcb72c1b
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}