summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-25 08:49:27 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-25 09:02:04 +0100
commit58ac6c33dc81851eb99f5cd7c46ac4d9602d0140 (patch)
tree83d02c2c9dd18ed117fc8a3dd74c3aea23718f8b /dev-python/dbusmock
parentdev-python/boto3: Bump to 1.17.36 (diff)
downloadgentoo-58ac6c33dc81851eb99f5cd7c46ac4d9602d0140.tar.gz
gentoo-58ac6c33dc81851eb99f5cd7c46ac4d9602d0140.tar.bz2
gentoo-58ac6c33dc81851eb99f5cd7c46ac4d9602d0140.zip
dev-python/dbusmock: Bump to 0.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dbusmock')
-rw-r--r--dev-python/dbusmock/Manifest1
-rw-r--r--dev-python/dbusmock/dbusmock-0.23.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/dbusmock/Manifest b/dev-python/dbusmock/Manifest
index 15401a2ea53b..a9f8cad4ab5e 100644
--- a/dev-python/dbusmock/Manifest
+++ b/dev-python/dbusmock/Manifest
@@ -1 +1,2 @@
DIST python-dbusmock-0.22.0.tar.gz 68626 BLAKE2B 51b897ad95bc547afe6cd59abed243dcaecd3c6ce8c47825f3a2eeaf7364c5aba04d23247c876f748b071f30753a86da954493bc63f0ae503085974e7e769658 SHA512 2c3430f4178a16acc376ce582f4a1a9bbe8b917efcd7eee58dab85ee3addf60ba355ae9e7b318ec2cdf7ca771183c37d16520a1e5bcab8414c66e2d2a36d26fe
+DIST python-dbusmock-0.23.0.tar.gz 79928 BLAKE2B a004bbc93cd4dd3ab5919e28bde18e7b015546e43b789826010ccfd2000075babf933bc53b72bc4369458ac6c37845b534b0e36e594afc4bfd298d9ac37495c7 SHA512 b464c376b1489bc2a9967d08fd1e4e8943e372f46eef46d1cebf316f4afd1f2bf55d02abc3b82b7052c685fe1ff9ba22734a58aa75945706a26ae9d71e5d807e
diff --git a/dev-python/dbusmock/dbusmock-0.23.0.ebuild b/dev-python/dbusmock/dbusmock-0.23.0.ebuild
new file mode 100644
index 000000000000..f2d09692c7eb
--- /dev/null
+++ b/dev-python/dbusmock/dbusmock-0.23.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="https://github.com/martinpitt/${MY_PN}/releases/download/${PV}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # needed for unittest discovery
+ > tests/__init__.py || die
+ # linter tests, fragile to newer linter versions
+ rm tests/test_code.py || die
+
+ distutils-r1_src_prepare
+}