summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-25 20:46:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-25 21:01:47 +0300
commit9ce9deb2321a91d4b0c0387fa91b78c92046dc95 (patch)
treef4f9a78f11045177c2a4009b0b45d3a7049ffad1 /dev-python/cycler
parentdev-python/crashtest: enable py3.11 (diff)
downloadgentoo-9ce9deb2321a91d4b0c0387fa91b78c92046dc95.tar.gz
gentoo-9ce9deb2321a91d4b0c0387fa91b78c92046dc95.tar.bz2
gentoo-9ce9deb2321a91d4b0c0387fa91b78c92046dc95.zip
dev-python/cycler: Use PEP517 build
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cycler')
-rw-r--r--dev-python/cycler/cycler-0.11.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cycler/cycler-0.11.0-r1.ebuild b/dev-python/cycler/cycler-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..234b1e78bb1d
--- /dev/null
+++ b/dev-python/cycler/cycler-0.11.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Composable style cycles"
+HOMEPAGE="
+ https://matplotlib.org/cycler/
+ https://pypi.org/project/cycler/
+ https://github.com/matplotlib/cycler"
+SRC_URI="
+ https://github.com/matplotlib/cycler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+distutils_enable_tests pytest