summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-25 06:18:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-25 07:39:37 +0100
commit74e5b8247699999ebf94bc9d8386ef5f9c2c50e3 (patch)
tree5df6f54bbec60949c2da51306eeda66fc8424d8c /dev-python/botocore
parentmedia-sound/guayadeque: Stabilize 0.4.7 x86, #902863 (diff)
downloadgentoo-74e5b8247699999ebf94bc9d8386ef5f9c2c50e3.tar.gz
gentoo-74e5b8247699999ebf94bc9d8386ef5f9c2c50e3.tar.bz2
gentoo-74e5b8247699999ebf94bc9d8386ef5f9c2c50e3.zip
dev-python/botocore: Bump to 1.29.99
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.99.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 3a0c4139075e..60498806757b 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.29.95.gh.tar.gz 11252473 BLAKE2B 500dfc60af5127b56d41fc8ffa2742b
DIST botocore-1.29.96.gh.tar.gz 11257444 BLAKE2B 28cea7e2909a4c1f5a399633dbaa52b87fedc25f4c9cfc9f7c9a977dc84f86dcb3da9d1109b2c77e815bb5338337c850f260d9c2adc27d1f8bd529f087c2a299 SHA512 a6c414e275d7b31eed94175fd54142a909b8957685ab6779488704c905595f83c0bf376d5d37386266b103a3efde1a46f853ac7b1631056069903c0c57b55da2
DIST botocore-1.29.97.gh.tar.gz 11258219 BLAKE2B 5bbbe250a80203d993ee2ad36770f839cbe6a086d63446f4b537c7015f686840726e15680762ece85869b676d51385c1302952ecd4a5607b2a07b9db1d0df9cc SHA512 0ef137c6a51546126000f5a7b8ff413d17d9684a36fdc7977b04cca090a757b76f1bd1cea02cd733eb4581c370cdd9214a033f7dc4766e02d2f1b5140c098e2a
DIST botocore-1.29.98.gh.tar.gz 11284537 BLAKE2B a0ab33b0a02483f54ecb42f6af61710758a2ec8333937910e74169888e4a3b6b72ae7d104f47daf6e47d45e95b94c907967eee9cbd5886463f7b22f46b8babcc SHA512 5d87896314e138f71bce64db23bd69dbdfd55599a3356b161307bff1550264f3f378586ad3aabcf8662476b7c7013337d2015614178e147a6cb56efeed28e159
+DIST botocore-1.29.99.gh.tar.gz 11285143 BLAKE2B ba594544fb219cec77659cfa48fb6e3a8241b92c911d9983450648ce97652cad7654181637fed8373fe49e33524f63920128afd4ca9c00bce45603b1ab917648 SHA512 319d70412843149aa43c8d7faeff04122d96091081d30c2da0962fadb27104a24cc147fac2c95492aa407b2f8a25ebed9e7d149c29d5d38134d836581c801bdd
diff --git a/dev-python/botocore/botocore-1.29.99.ebuild b/dev-python/botocore/botocore-1.29.99.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.99.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}