summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-18 06:03:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-18 06:43:36 +0200
commit679f2572a57fe1e3817184d91250dc7478b5532f (patch)
treed257610c801b7f003267e927ff17531e99e6ea03 /dev-python/botocore
parentnet-irc/soju: Keyword 0.6.2 arm, #912245 (diff)
downloadgentoo-679f2572a57fe1e3817184d91250dc7478b5532f.tar.gz
gentoo-679f2572a57fe1e3817184d91250dc7478b5532f.tar.bz2
gentoo-679f2572a57fe1e3817184d91250dc7478b5532f.zip
dev-python/botocore: Bump to 1.31.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.29.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 2429b75ad1de..6dec54cfbd70 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.31.25.gh.tar.gz 11863108 BLAKE2B 2fb9bfc01ec93e1dff3459e89f7b209
DIST botocore-1.31.26.gh.tar.gz 11865968 BLAKE2B ead40328750793f1cb6e4b533d3cced2eb5a33a6ee7fd81f96853b8ccbf7f3b15977eb2b6c8e218e898d06b0ed087ab1a1919860e45c7afa1b93989b01992b71 SHA512 a0949446d371a34552134903aa5d3ecb8d2fd77a128610c28152d365ffd882cccf8ae419c87b649d48fe732c6b3de04620f4ab7915199f014d9368f0a446abd5
DIST botocore-1.31.27.gh.tar.gz 11871182 BLAKE2B 818464a312ebf32eb38956fe6d58a1c784e9f2c746e8a03070ceaba89f3a3aee6fd5ff190f6001d32c46a92c12958c5655b5f07c9545b7f8ab6c8b060f1f3656 SHA512 9a175150ada4b21c3c2992671c69bea8717a934009fbf1fa30955735bf732285301e1a7013c631d6422c911b5e62f2980c191e41b9af4479bbe3a0ee8c44e71a
DIST botocore-1.31.28.gh.tar.gz 11872151 BLAKE2B 97541606ddc488cc1b07f02a1ab55939596f6fcf8515b19579e7c836b4b5fb7cb41c04b1b15e4836b8bf33982044db93694371a8c966682ad4f22ab973041f30 SHA512 88956b9537e6db15c0a5976b25a63d01a0fbe12f8220a5ee3028b6ab6118a3384db3749a8cd2ff2ad32393a419145f9c8027842d290e7bf655b063adf50fd984
+DIST botocore-1.31.29.gh.tar.gz 11874948 BLAKE2B a4a2dabdfdb574814878009a29cee4dfd2014a45b40e10f4769b49d487de1f58e75f27ac897cc140590b03922dd1c2bfc6e28ad211d45743f5358b80fef238c4 SHA512 5796b5b985b68ebde998133c6b33ef2bcc3b7f64615198e0e73f6e24fd2782b796a3acd8a3603cce0890ad820d00c2021da5bdf408ea89154ad21bfafb71c738
diff --git a/dev-python/botocore/botocore-1.31.29.ebuild b/dev-python/botocore/botocore-1.31.29.ebuild
new file mode 100644
index 000000000000..5894fd995097
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.29.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}