summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-03-11 02:00:56 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-03-11 09:13:30 +0000
commit1c1f613b81dd449268137220e8f157e174f57626 (patch)
tree58e09369df2b62e85bdbef198f959e4db4972568 /dev-python/botocore
parentsys-apps/keyutils: Don't check for KEYS_DEBUG_PROC_KEYS after Linux 4.0 (diff)
downloadgentoo-1c1f613b81dd449268137220e8f157e174f57626.tar.gz
gentoo-1c1f613b81dd449268137220e8f157e174f57626.tar.bz2
gentoo-1c1f613b81dd449268137220e8f157e174f57626.zip
dev-python/botocore: add new version 1.9.6
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.9.6.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d9765c30411d..ac9d5c3f391c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.7.39.tar.gz 3838231 BLAKE2B 53355a6f0fca131db8ae41ff7e0b5405dc2a4c1a0630743ec34e0fabe60468d27ea9d36b67dc3b8757c3f524eabf3fef1e55d3eb0df1f4c5bd229448f8dfc3d4 SHA512 0a6031315356f43e00ba5661020890478a589f0524bacd22fd24a9f8da147761f70d7b7fae9aab887301e78a392bc12dc7067174af9a07aac346d11a4cec9a22
DIST botocore-1.8.20.tar.gz 4173990 BLAKE2B ce9813c77b440fdfd123593aeb9f5c47bec877981dad5089b83633deebab3bf4aed76c13ac73f571eeb8349406b3f04e6c33634a865e076ffdca266cf418b80c SHA512 0b822bff75ef26c7e996e354a5c06cb50eb13d7e58f65297adcf023a81084c8b98500c08b906dcfd346e2dadcdde33d472d6d51c3e081af8667c5adcdd2deffd
DIST botocore-1.8.41.tar.gz 4196554 BLAKE2B 8f74b8f53fb98ea0fbadebb1739799eb30fb52748377175e0682292f4868910a5fab187c9065434e67d783eee0bb119555daa55020f1b909370749dfdf1dbc87 SHA512 d8bb3eb704268410646c0290fde829a3f69fc9c587b31afb43649efe345f626dc902be0ba7939239bb93871138aeb7587671dcb91ac40f4241c90b2238219d30
+DIST botocore-1.9.6.tar.gz 4214248 BLAKE2B 7d15cafd899a3b0ed139ebcc603a2eb2157b64369744620aff6d80a6186ce89d26315af7d40ca71e1b3bb2b258854f6335586ae635aba37ee2a8b8b0ab45aaea SHA512 bd69eaae4b4fdbf161e30191b1b715adca0316ab5c55c73a845291e42279a23110ff942a72997126a8dea47e0fe15516eddc42b6c08bd2bb9e86e8ecfcb73270
diff --git a/dev-python/botocore/botocore-1.9.6.ebuild b/dev-python/botocore/botocore-1.9.6.ebuild
new file mode 100644
index 000000000000..89ab97de7bc5
--- /dev/null
+++ b/dev-python/botocore/botocore-1.9.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.7[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}