summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-10 07:30:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-10 07:30:40 +0200
commit225d9449fbedc1c73b3c0a7bf8add52d0eb04b79 (patch)
treec7209c19972c285c717c0e66fcf0385f6c4b3d0d /dev-python/boto3
parentdev-python/botocore: Bump to 1.18.16 (diff)
downloadgentoo-225d9449fbedc1c73b3c0a7bf8add52d0eb04b79.tar.gz
gentoo-225d9449fbedc1c73b3c0a7bf8add52d0eb04b79.tar.bz2
gentoo-225d9449fbedc1c73b3c0a7bf8add52d0eb04b79.zip
dev-python/boto3: Bump to 1.15.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.15.16.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index d187ce5def14..6de309e6660b 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -9,6 +9,7 @@ DIST boto3-1.15.12.tar.gz 336150 BLAKE2B c6817e39fb19cd40f7cdcf6140303bd1993ec11
DIST boto3-1.15.13.tar.gz 336233 BLAKE2B d82c38c4021c4f76ba5aa37c2b6328cd4870c3d64b343d2ccf4d441c231243ff369d91ec56b45380ca19b1b35a3934c548bca41a61832a7ca519e4119911c383 SHA512 5e50a212f1b47c79e75d3f2dc6ace0984c82041c11a8c87c831cf3ed2452234089b3f91be05af5342893ae377ad3e119e5e2b5f329cf200a877a46f418b55cc1
DIST boto3-1.15.14.tar.gz 336351 BLAKE2B 61e4ee1b235c07dc3d0d961a3e4b6138c79ee49a9d9e80b15d68d9f1d3bf7eaddc3f993f7de914d2f8ba939d0508875a912b87c58570f91e726a5b44198c2adb SHA512 a40c123b017d45dc100d70d66a2cd7850dbfe5cf3fca715d3f6226e23423c7710a157ec7567d9d9f45311bbb764b47b281c9a3757e9910c4453451bec385383a
DIST boto3-1.15.15.tar.gz 336346 BLAKE2B 1dab0b7810cba83b28391b50e8c24a50d051827c090f7eb1b9511ecdcfcf625986aba639e292439315a413029c4392fa7a795ab154819ee7ac5dc7cd476169fa SHA512 b6ffe472bac7c6a12d9a1c901ddf9ed55368913e242421282e003eac1c02ad3336993e3c4343e5b8b624ea981e78df2536a41c74f42cc2e8a0d4f46d315200a6
+DIST boto3-1.15.16.tar.gz 336442 BLAKE2B 106c6bb5ee8ce43a11f486204528e04fd53a23e30ed58346782183e95e36dc25c1739915d3dc5bf3cd739cb93b7690f616d3273d0d8427c4f057003e075463e0 SHA512 21803d329964c598584d7452b83458dce6a8c3a36abc1c966f4db4386ac401ab78082973db789d1fccdd8f1866807793462a8197e3b4d75320dd0ec15f6187f0
DIST boto3-1.15.2.tar.gz 335231 BLAKE2B f1eb144da7afc1cf630cdc1f61880d094186a37d46556ae361da278fd3045a119dcb09c3d08387a019ca88d6502fa8710a5e5733cd9dc9056676ef17853d76e2 SHA512 6866e0d6a50d11495e5f2a33a392b0edbe1ff6625235b26b5d6028f7c2c7089d78febe17b982f65dc2564254800a23409247ac09716b099f09f3751c5b7f47b5
DIST boto3-1.15.3.tar.gz 335286 BLAKE2B 05c9ef757b8d227ae06a22e78d978821ff50da719f122ac025940b2e1ac5728d6bac044d4bfab95c56ac8c363efd7abfe3de2b3fd65d423ab53dbdfc60b910da SHA512 dfecfc075896ce84fd58d0437b84a6a794af69ff3e598b35b43f83b2b5ef57b88f96ef62a0d6505d5fe7fef0401513c8ecf0dfcaa22e4575510acd3ece191901
DIST boto3-1.15.4.tar.gz 335401 BLAKE2B 42ee1f2cf1e82338ea59a40b95aa5c76abae51aacf325ae845f407ccbc3caf1b3901bca48036889ad6307f96c257259cce39784a3f52ec6ff03c0c6c5633c654 SHA512 14626faa3943b65a215b8f1bce24f217e69421cdfd40caaf7de0fec13ca9b5b25c5e290c27672b2a6bc41316917224209110e2efd5be817de7273f93ae5764ce
diff --git a/dev-python/boto3/boto3-1.15.16.ebuild b/dev-python/boto3/boto3-1.15.16.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.15.16.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}