summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2017-11-04 01:42:59 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2017-11-05 00:52:16 +0000
commit210113723a7c81a38ba4e793ddf34dda6c4947d0 (patch)
tree5f8fe5cd64e74ee98d6f6f9e0dbf2863ce4e8fd0 /dev-python/boto3
parentdev-python/boto3: add 1.4.6 ebuild (diff)
downloadgentoo-210113723a7c81a38ba4e793ddf34dda6c4947d0.tar.gz
gentoo-210113723a7c81a38ba4e793ddf34dda6c4947d0.tar.bz2
gentoo-210113723a7c81a38ba4e793ddf34dda6c4947d0.zip
dev-python/boto3: add 1.4.7 ebuild
Copied from 1.4.4 ebuild with such changes: * stable keywords downgraded to testing * dev-python/botocore dependency versions range updated to require 1.7.* in accordance with upstream setup.{cfg,py} Acked-by: Alex Brandt <alunduil@gentoo.org> Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.4.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f50c5dc4a525..2f6222d4691f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.4.0.tar.gz 183263 SHA256 8fdd3743e34a32e5cb8636fb33dafe7336b7a34158
DIST boto3-1.4.1.tar.gz 188341 SHA256 a7f10245b3ff947019963963b73911c515debed89709740586503ac22f5dfb97 SHA512 525f2db50d0a9d6f452c0261e934ecd9f06b576154b128d209a729b0fe96190e641369c00e13700f2aba5fe4a0c02f80248e25bc3d716cb72752d645e880eb23 WHIRLPOOL 195e5dcd59152ef09ae1f32aa9f321ea1f57c2ac20f7a233673c4f2a4529c062f78af0641efe8ac0632188e8e85e1e687eeb7c6932de89d3c49e110df2958eb4
DIST boto3-1.4.4.tar.gz 194721 SHA256 c760ca47a34fb54e44b90fc28d87a50353df527b39e815f399c481bab7d351c6 SHA512 948d753809e41bad39fdf3da9646b62ff2fbc9d23966cdd0e46b2df18b07ff8c8af11bb777aa0cd1fea5bcdbc2d43f3f3d06012e30327e3c55b36f7bba815a61 WHIRLPOOL e650e194d507dd405034ffb7907ab4a7e22765f290bf0bd8d866bbd0f94afb5fb64a6395aef24ea2196700be3d893bcf6cc86223a5073577875e451aed75724e
DIST boto3-1.4.6.tar.gz 217110 SHA256 457ac301b28addece2914da6fc4207146a0f4393f8e94888315b1611a4f43270 SHA512 194be548af8b11fa14721a23934a811717c6e8a70178682c392626aaf97fd5738c7aeb83366d7951c2b69d63acc83f26059e3f0cb0b26f5d412ba606e02315e7 WHIRLPOOL 842a3f65f4a733f3e66cf66fdf45d4ca0a83d9d01164a5ed784f2a3328229471487f1ec67c82a7732d9196907859046b7246586fae64ecec4e2ec4565fe70fa9
+DIST boto3-1.4.7.tar.gz 217171 SHA256 b4952103bb0a1e0d9c1d3a06f51674bb2f1b3914cd667070fede5662ff5f381f SHA512 db87ce873ba3d7d12c9e77ce329db3fab25328407ec5ba7fa1e7c94351285a84a3baf0f71721ee6858761743736497ec35b03e8d5e9a59da8daa176596f1a1a3 WHIRLPOOL 2e2a79aaf5cb5525c1b15348baeb8001795ca08f1a932cc8f9874eda41e3527c4887e0e1a67d42e9e30cb703eff468d380d921fadf514d91983629854158f32c
diff --git a/dev-python/boto3/boto3-1.4.7.ebuild b/dev-python/boto3/boto3-1.4.7.ebuild
new file mode 100644
index 000000000000..62068e0e3877
--- /dev/null
+++ b/dev-python/boto3/boto3-1.4.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/botocore-1.7.0[${PYTHON_USEDEP}]
+ <dev-python/botocore-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.1.10[${PYTHON_USEDEP}]
+ <dev-python/s3transfer-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}