summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 06:43:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:16:22 +0200
commite03bfe16a6d02e7345fc523f81b8fa8e25a13537 (patch)
tree2b6626bbb0e7f04fdaf8ec0213f2bf27e0c824b8 /dev-python/black
parentdev-python/aws-sam-translator: Bump to 1.79.0 (diff)
downloadgentoo-e03bfe16a6d02e7345fc523f81b8fa8e25a13537.tar.gz
gentoo-e03bfe16a6d02e7345fc523f81b8fa8e25a13537.tar.bz2
gentoo-e03bfe16a6d02e7345fc523f81b8fa8e25a13537.zip
dev-python/black: Bump to 23.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/black')
-rw-r--r--dev-python/black/Manifest1
-rw-r--r--dev-python/black/black-23.10.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index 44b716301036..89bf53413632 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1,4 +1,5 @@
DIST black-23.10.0.tar.gz 595880 BLAKE2B 978f0334abd1085ae9d6b085510c938235fb4b94ac0ecc4f13754f36d3d3152d4c5075d0177c5492a50cc45e8feb4af8d8eb023516d2fe85c0c61fa4b1eb8fb4 SHA512 2d24a269e66e07473afb0eeb0e25472ed53b20a4dad3622319cafd2f90f2615b4eba39971269c75208c439bfc430ca9b4922e7cce6ec9bd28e648cd62b75aea4
+DIST black-23.10.1.tar.gz 597307 BLAKE2B 1f7522653e6eb537bd57826c8f4efc0520bab6a62b4ba5718fbd841bad046cd0a62edd5a87e8d5884e80b5882c712304e48f2af75770bd6b25e85dc7b262dc71 SHA512 493c46e01411ba6fc4ed81362dc056fb6171a9ec4d85142e5018e610b887b4ed674a09b6b0ede7cd53504904400adbf8b914b37cf0e73a0abaa2eef469a9ec02
DIST black-23.7.0.tar.gz 586177 BLAKE2B 4bb50b6c7409a97aa277f1048c17101a1c91368b9269cf4c08d3052c036887d2ed6e5f1f2e044c14f41bf2d969d65183413c2a9810f12d96cbf09778c9b1310e SHA512 78d5e87bfef4dcaff007455e8c72dcd45f9374c09da6f4ba45ae7caa980005d1bc984c68fa44d4abf7969a376a4039546e7e8f537c3aa1331d213e13dcbe3941
DIST black-23.9.0.tar.gz 588540 BLAKE2B f3c94acb1af6c4bf1ada948d4ea7b7cd243184b920fab7e741d9e5ee4a82e163e5570ca1451424ea379362ae1755907e4b5e63b517a4e420d6cbe9d69655a10f SHA512 4d1ae51353c7a0a4113796fcc10824228d5bd9a0f19474efc8c5e3a9b929433a586f058521fd1dae35301e9e33e6d231b0584f81514104ac5c787f8e55cb9fa8
DIST black-23.9.1.tar.gz 589529 BLAKE2B 642e1bb7b83653d879b3cbf1e618472a3106c1d9c918cbb57e5f517a96a8838a501f0e49f0fa1822d87600b4a8cecaac8da2bc9f08d5bc4131a611a90099f60a SHA512 0732409800a131fee69fffa8e7be8c128d26f0f75038235ba6f8c7451901199eed4118a2cb640ec0a5e6b40238bf41991c4a0559534f3a9f13d29f118e5b4aaa
diff --git a/dev-python/black/black-23.10.1.ebuild b/dev-python/black/black-23.10.1.ebuild
new file mode 100644
index 000000000000..29726cd5e4ea
--- /dev/null
+++ b/dev-python/black/black-23.10.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing optfeature pypi
+
+DESCRIPTION="The uncompromising Python code formatter"
+HOMEPAGE="
+ https://black.readthedocs.io/en/stable/
+ https://github.com/psf/black/
+ https://pypi.org/project/black/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
+ dev-python/aiohttp-cors[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+pkg_postinst() {
+ optfeature "blackd - HTTP API for black" \
+ "dev-python/aiohttp dev-python/aiohttp-cors"
+}