summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-02 10:37:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-02 10:38:52 +0100
commit03c48972b1e0c8faaa03e12302a497c9d2edabd5 (patch)
treeb7ffa068d7bb44187e8993683b5ccfd4cb573282 /dev-python/async_timeout
parentdev-python/django: Remove old (diff)
downloadgentoo-03c48972b1e0c8faaa03e12302a497c9d2edabd5.tar.gz
gentoo-03c48972b1e0c8faaa03e12302a497c9d2edabd5.tar.bz2
gentoo-03c48972b1e0c8faaa03e12302a497c9d2edabd5.zip
dev-python/async_timeout: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async_timeout')
-rw-r--r--dev-python/async_timeout/Manifest2
-rw-r--r--dev-python/async_timeout/async_timeout-4.0.0.ebuild37
-rw-r--r--dev-python/async_timeout/async_timeout-4.0.0_alpha3.ebuild36
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/async_timeout/Manifest b/dev-python/async_timeout/Manifest
index 697283481f4f..430fc6d9d860 100644
--- a/dev-python/async_timeout/Manifest
+++ b/dev-python/async_timeout/Manifest
@@ -1,4 +1,2 @@
DIST async-timeout-3.0.1.tar.gz 9724 BLAKE2B f18ae75969b7048469fe22949f25ea25da3fdbf08b98a16b5d5ffe823060a75e6de9ed764727e08d4344c79426e9c89013d49522f20ed62e6fbe912b5c7a8787 SHA512 fd30842671a79edfd52c7350e7fb2120533a6d97b44975f7b071ce2cbde43443bd5bbe1f2ad0ad3ab2156e1987b9e58e0c149b0ecfea8674eb0cb78eee79c986
-DIST async-timeout-4.0.0.tar.gz 8258 BLAKE2B 7a3edee9491aba11e59ef6bf7c07b9e3f00e97bf42e69adac92a23d89715e2c90dbf9e431c146c20e44b05ed47905cfd5afa41fd04df63315d9f347a6b8f70f1 SHA512 92716106b42ad3746c9873649b44d414da08f75cd507a0dc45d764270bcbd6f483c149e5cebe1a4c36f5cd02397c21b67b92a0475117d9dea17c580e422cf4da
-DIST async-timeout-4.0.0a3.tar.gz 11386 BLAKE2B 8918878c4edd64c70d831ddd05e3235c3c7cc116a99755205b7624df52cacfb61bf4e80083c85d93e420fbf18e7da16ee3ebc796c5a4890e2801885b670a494a SHA512 04775ea30ffba90a4b604ef040df24a6a2711fd3e2c3b45d1ab87ae3487f216458f44bbfb2c85498bef286acca90af43d8b3b95cf22244027c0a48494ef84e7a
DIST async-timeout-4.0.1.tar.gz 8030 BLAKE2B 73bb3f38d33608d120a0d633231bc781b9b5530d80a08c98370ab9100486bda5fd9d7a68ae6b16315bf306a75690897d724fa5db318847803bc445074908e650 SHA512 24a72daf9e0737d0be351a35ff28242dea735bed33f06d9865a71983b1341693c80856c0668d6a485bccc8cf7b9adde33fa904e94bf4730e4a678216e572d119
diff --git a/dev-python/async_timeout/async_timeout-4.0.0.ebuild b/dev-python/async_timeout/async_timeout-4.0.0.ebuild
deleted file mode 100644
index b5f424cc0c74..000000000000
--- a/dev-python/async_timeout/async_timeout-4.0.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_P=${PN/_/-}-${PV}
-DESCRIPTION="Timeout context manager for asyncio programs"
-HOMEPAGE="https://github.com/aio-libs/async-timeout"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # remove pointless dep on pytest-cov
- sed -i -e '/addopts/d' setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest -p no:aiohttp
-}
diff --git a/dev-python/async_timeout/async_timeout-4.0.0_alpha3.ebuild b/dev-python/async_timeout/async_timeout-4.0.0_alpha3.ebuild
deleted file mode 100644
index ec9fda7ab9ba..000000000000
--- a/dev-python/async_timeout/async_timeout-4.0.0_alpha3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_P=${PN/_/-}-${PV/_alpha/a}
-DESCRIPTION="Timeout context manager for asyncio programs"
-HOMEPAGE="https://github.com/aio-libs/async-timeout"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # remove pointless dep on pytest-cov
- sed -i -e '/addopts/d' setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest -p no:aiohttp
-}