summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-30 06:15:07 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-30 06:48:12 +0100
commitf1303729eb1063ed02b7fe21076aa1cb3e7e7fb6 (patch)
tree7dc7c66ac37872b25dd683b83c2d1796bcb2144e /dev-python/apsw
parentdev-python/rpds-py: Bump to 0.13.2 (diff)
downloadgentoo-f1303729eb1063ed02b7fe21076aa1cb3e7e7fb6.tar.gz
gentoo-f1303729eb1063ed02b7fe21076aa1cb3e7e7fb6.tar.bz2
gentoo-f1303729eb1063ed02b7fe21076aa1cb3e7e7fb6.zip
dev-python/apsw: Bump to 3.44.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.44.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index fa0c99d07f33..53c0e681b42f 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -4,3 +4,4 @@ DIST apsw-3.43.1.0.gh.tar.gz 901289 BLAKE2B 3f463896ce587326421ae78a26b5cccbc5c4
DIST apsw-3.43.1.1.gh.tar.gz 901590 BLAKE2B 0fb1942aebf60443c12901e1b21bb7b9fce1e90d406bca80580563cee2d8aaf45b9c2294317cf374484fccd8b595439e13df01b14512514f78ec60ae1e905990 SHA512 3121e594a9d4c358ecb2f90becadc06fe987a3e7d6897fd655d5ae9aff6c8d1521257c2a34a68a8e6114cf7a71479544433e599522bee93e3fb729ee9763a112
DIST apsw-3.43.2.0.gh.tar.gz 908230 BLAKE2B e583cbb5c636b9d38762668d8cc664c7342e50a4330d3714a93679043e322ea03cf7c9bf09396ea5025e74ab66747fc509790e4f17fd722a654d6f8d1774949d SHA512 760ebef288bec4e08a06fc8e1e720e9c51ada19196efb7491988c7cab31dc54f9082c5cc668acf04d28818dbcd41a8a45df66c1fd78d2716862ec9a2faa022ed
DIST apsw-3.44.0.0.gh.tar.gz 899926 BLAKE2B ce162d757fbf5510355419dd279ea33235e8cdbd7a8b03f0288f730b66cad9d6aa09c91a3fe97f930422a1b8158c9b22d9ae8d5ee03dec657319a3bf6f24a04f SHA512 4cc4cacdbc03e522d149507bb875ae880bcd5b0130bb3babda7d873c52b3db362c8347ce6af412dc3a73b1fb8362d1c1fe9a51b2343b0c52ff1812582d91c564
+DIST apsw-3.44.2.0.gh.tar.gz 902852 BLAKE2B bdaf72ef063d3ddaf46bf403e688ffe5ee657de5a17ca3aba496058d8f244fdfd82b41899f3c944b6d7cdfe5bab0e7608bd26db926016df6af9fa5a950c12415 SHA512 76f8b92feb792c3003d251bcf61dab80bfb34147cfb8512ad6ff1dd1f07b4e7a5c97b98c4bfc7fee179efc7439ea28573552ae25d5bc33e633da0722866fd551
diff --git a/dev-python/apsw/apsw-3.44.2.0.ebuild b/dev-python/apsw/apsw-3.44.2.0.ebuild
new file mode 100644
index 000000000000..21c2e33d0999
--- /dev/null
+++ b/dev-python/apsw/apsw-3.44.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}