summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-21 06:20:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-21 06:32:26 +0200
commita99b570a7e19be5dd3a7ff90af61a2648bfb3d0c (patch)
tree354fa48ef635ca85a9c5814df617184d689df2e7 /dev-python/apispec
parentdev-python/fsspec: Bump to 2024.10.0 (diff)
downloadgentoo-a99b570a7e19be5dd3a7ff90af61a2648bfb3d0c.tar.gz
gentoo-a99b570a7e19be5dd3a7ff90af61a2648bfb3d0c.tar.bz2
gentoo-a99b570a7e19be5dd3a7ff90af61a2648bfb3d0c.zip
dev-python/apispec: Bump to 6.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-6.7.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index bc020e636e0d..2ed1169cc8a0 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-6.6.1.tar.gz 76537 BLAKE2B e08f1545441be7f1dd266205a6a7dc1317385961325e47c25fde0aecbd68712410601249bced9b0c3491d3e6f772c94c14f638d77e3dbfac37bba5bb0dd1e284 SHA512 a6820444b017f9551d21cf5ba5a14f8f4eaa6bccd1848c540e41bd37140df06dc897bf5d29bc77a2e55b670d58dc84eeb6588769efb3fe400eba243c0a1b5425
+DIST apispec-6.7.0.tar.gz 76654 BLAKE2B 95b0daa8c6b07bd4accf84a8f4259d9c7ebed34ad0e9767c53548b13a82bc0de7bf3b145905f380106bfc07cfa10a942f290d93d1d3599aa8fe76df23863a3b3 SHA512 b75482696aecd6a68bd35ba1e4112c3ead7475c7f5dcca49f0ec6f332f37ed8e42df152164b645716f86daaafbb59f94c3f4844705d3df5263e637e9fa90afcd
diff --git a/dev-python/apispec/apispec-6.7.0.ebuild b/dev-python/apispec/apispec-6.7.0.ebuild
new file mode 100644
index 000000000000..b4c64b64045b
--- /dev/null
+++ b/dev-python/apispec/apispec-6.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}