summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 14:08:12 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 14:17:13 +0100
commitf3726e6f42e2e963fda8663ed8a359c54bc1027e (patch)
treeec9e634f9f83e8f65f5bed8f832df0d0777f645e /dev-python/apipkg
parentdev-python/argcomplete: Fix remaining MissingTestRestrict (diff)
downloadgentoo-f3726e6f42e2e963fda8663ed8a359c54bc1027e.tar.gz
gentoo-f3726e6f42e2e963fda8663ed8a359c54bc1027e.tar.bz2
gentoo-f3726e6f42e2e963fda8663ed8a359c54bc1027e.zip
dev-python/apipkg: Bump to 1.5, fix tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apipkg')
-rw-r--r--dev-python/apipkg/Manifest1
-rw-r--r--dev-python/apipkg/apipkg-1.5.ebuild24
-rw-r--r--dev-python/apipkg/files/apipkg-1.5-pytest-4.patch25
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/apipkg/Manifest b/dev-python/apipkg/Manifest
index 176961da12c6..79087bd26416 100644
--- a/dev-python/apipkg/Manifest
+++ b/dev-python/apipkg/Manifest
@@ -1 +1,2 @@
DIST apipkg-1.4.tar.gz 11224 BLAKE2B b59e3fe39030f1f1f7f41e121d7a4e242d7155be5f7b2b8f3cd7550772acceacaf2d9540cf98bdb51e6d132af937d634bce3699b950b9d9aa9a618009cbaebb8 SHA512 118f806706944513f50d3cdef596b32f8ce585cfaf94d2531a6d260f90a0e2147177161aaa6f5d6823150e6182d0f73be3dc01259b8a2f8d710733a22ea54789
+DIST apipkg-1.5.tar.gz 11186 BLAKE2B f703a37b38b412228348520a9daa0276a69c3be47a9586e1c2797cf525a024bb0fda81dbfad7d4b1404e1ebcd3eec0e9ce2231beef5072bf9915240e2e5fb445 SHA512 828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf
diff --git a/dev-python/apipkg/apipkg-1.5.ebuild b/dev-python/apipkg/apipkg-1.5.ebuild
new file mode 100644
index 000000000000..63525d9df7f6
--- /dev/null
+++ b/dev-python/apipkg/apipkg-1.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Namespace control and lazy-import mechanism"
+HOMEPAGE="https://pypi.org/project/apipkg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest-4.patch
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/apipkg/files/apipkg-1.5-pytest-4.patch b/dev-python/apipkg/files/apipkg-1.5-pytest-4.patch
new file mode 100644
index 000000000000..0053e7078e2b
--- /dev/null
+++ b/dev-python/apipkg/files/apipkg-1.5-pytest-4.patch
@@ -0,0 +1,25 @@
+From 81dc0f46754afd44358b8c97ea832030436ac7cb Mon Sep 17 00:00:00 2001
+From: Andy Postnikov <apostnikov@gmail.com>
+Date: Sun, 27 Jan 2019 03:27:18 +0200
+Subject: [PATCH] testing/py-apipkg: fix tests
+
+https://github.com/pytest-dev/apipkg/issues/14
+---
+ testing/py-apipkg/14.patch | 11 +++++++++++
+ testing/py-apipkg/APKBUILD | 7 ++++---
+ 2 files changed, 15 insertions(+), 3 deletions(-)
+ create mode 100644 testing/py-apipkg/14.patch
+
+[inner patch extracted for Gentoo use]
+
+--- a/test_apipkg.py
++++ b/test_apipkg.py
+@@ -13,7 +13,7 @@
+ class TestRealModule:
+
+ def setup_class(cls):
+- cls.tmpdir = py.test.ensuretemp('test_apipkg')
++ cls.tmpdir = py.path.local('test_apipkg')
+ sys.path = [str(cls.tmpdir)] + sys.path
+ pkgdir = cls.tmpdir.ensure('realtest', dir=1)
+