summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-20 09:56:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-20 10:27:44 +0100
commit40aac247f2a7ec3c1a383d34f370fddb665d6bf9 (patch)
tree275b9ccc9ed5c30658ec0de8e5a3605a00e21fa1 /dev-python/alembic
parentdev-python/croniter: Add python@ as co-maint (diff)
downloadgentoo-40aac247f2a7ec3c1a383d34f370fddb665d6bf9.tar.gz
gentoo-40aac247f2a7ec3c1a383d34f370fddb665d6bf9.tar.bz2
gentoo-40aac247f2a7ec3c1a383d34f370fddb665d6bf9.zip
dev-python/alembic: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.5.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index df91474bd950..4b28a7f7e09a 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,2 +1,3 @@
DIST alembic-1.4.3.tar.gz 1108131 BLAKE2B d9c8b6d6aebce7a45194dd6c654f4a2627714a5c1f7cb7a1cf80ed8c3fe861e3bb7857811128787ddd6c093b4370784b40cddb385cfbd30f6134d537fe949d2d SHA512 925d8957fd9008d041737a9e79ec8d7a4c5deba1976e980362d355a75348c1638d783d9d48234a5bc3b2dc3f2f09dcb281d0c80ae0f0c5bc32e176c3dfa05463
DIST alembic-1.5.0.tar.gz 1128073 BLAKE2B 067ebe7a8ee9b14fc782e0f5268990b07a8ae91ab8ae89daee119bb64f30b8cb966ff22ce71c67e476fafce7ae418952f253645b0f5b5b8a1abbf7f562794138 SHA512 a667e5b176770061c27ea7fdaafdbcdad64d968e22e729083fadd8e002530cc43909a955c3ccaa04329c393ab3f27ec5b944b03ba0ae5d29609b940e7cfb8ad5
+DIST alembic-1.5.1.tar.gz 1128404 BLAKE2B 70a2ce16adcf317c9376f77d8fa88e9eef3aa4090de5f933187f47df9fe6ac40a25df75d6c74c50c3be23dd3cef13d465eb2ddae4ea83558d01ebffd8effe241 SHA512 2fe490c46c253123333f0496fe28b59956efc78924f145b69ba95e5cb1cc091a72047c1aa5f8a85924ec59ad0aba2bfa143b9cad475dedc6f849c38695c08601
diff --git a/dev-python/alembic/alembic-1.5.1.ebuild b/dev-python/alembic/alembic-1.5.1.ebuild
new file mode 100644
index 000000000000..32d428a7bdf3
--- /dev/null
+++ b/dev-python/alembic/alembic-1.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://github.com/sqlalchemy/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}