summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-26 02:48:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-26 04:09:27 +0200
commit56e29784dac423e3af6f782a00434e8b7da6f9f0 (patch)
tree82a32b30db87e0461a5c40f83828704f1b617a06 /dev-python/Faker
parentdev-python/hypothesis: Bump to 6.104.1 (diff)
downloadgentoo-56e29784dac423e3af6f782a00434e8b7da6f9f0.tar.gz
gentoo-56e29784dac423e3af6f782a00434e8b7da6f9f0.tar.bz2
gentoo-56e29784dac423e3af6f782a00434e8b7da6f9f0.zip
dev-python/Faker: Bump to 25.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-25.9.2.ebuild42
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-25.9.2.ebuild b/dev-python/Faker/Faker-25.9.2.ebuild
new file mode 100644
index 000000000000..bef66c8c66a9
--- /dev/null
+++ b/dev-python/Faker/Faker-25.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+ EPYTEST_XDIST= epytest --exclusive-faker-session tests/pytest/session_overrides
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 5813f2f8ccb7..a337ab451f94 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,2 +1,3 @@
DIST Faker-25.8.0.tar.gz 1760950 BLAKE2B 89b18875ae2c3934423d4e7ce9d0da048830f73384db73589372791c6a1798254e3cab54b566ecfbe3263c44edbe12f2c3e7e0d6cbb004e6fc09e9b2e12f7e89 SHA512 88d0c073b48e0df050d3601d97223d64ccf04ad57d59cb37e26a40211633b04301000e7ce12a124e97b32b63225b440f5b44e1d6197f9c8999f7dd0b579a075e
DIST Faker-25.9.1.tar.gz 1762549 BLAKE2B f331ba11899f0711a74aa4c6a3f883113c00ef16960816b26163be2355bfd1aeda1e01fb5ff430d5f34f99a21e74195d8cdd1fb44fb23e3870a6592242564ab9 SHA512 191ccf0cccdf125cabf2af20cf74681d3aa28038eb2551f7e1cd3a285b17e2fc1d8b245888c44d9a1f66b1f9a5ddc1847ff2e421ef9fb8732efeb56e0957a898
+DIST Faker-25.9.2.tar.gz 1762726 BLAKE2B 75e11d91eae914a8093e448802924e2bc63815317a36870909709648389dc4d55fa1951b588a7fa6ed1cf1468724158abc16342465156d00e66f1febb545d47c SHA512 6f1272b64bc973f3e9f32bff589aedf8db35ae3c90ea9d459babaf47e327cf26199f05a5cbc888c13aced41722e91335b8c34685b9bebda4a939aad89098bbd1