summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-03-21 11:15:05 -0400
committerBrian Evans <grknight@gentoo.org>2022-03-22 08:28:55 -0400
commit8090eadfaf1507fb04c7acffecb2fb2b329741aa (patch)
tree8370ff53ec45995135ac45e7b3a139d784b587f3 /dev-php
parentsci-visualization/gnuplot: Remove old (diff)
downloadgentoo-8090eadfaf1507fb04c7acffecb2fb2b329741aa.tar.gz
gentoo-8090eadfaf1507fb04c7acffecb2fb2b329741aa.tar.bz2
gentoo-8090eadfaf1507fb04c7acffecb2fb2b329741aa.zip
dev-php/pecl-radius: Adjust targets
Dependencies are deduplicated here as well. Does not affect installed systems. Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild b/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild
index 467867d6f62c..fbb86a1f78f8 100644
--- a/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild
+++ b/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
PHP_EXT_NAME="radius"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
-USE_PHP="php7-2 php7-3 php7-4"
+USE_PHP="php7-4"
PHP_EXT_PECL_FILENAME="${PN/pecl-/}-${PV/_beta/b}.tgz"
PHP_EXT_S="${WORKDIR}/${PHP_EXT_PECL_FILENAME%.tgz}"
+PHP_EXT_NEEDED_USE="pcntl(-),sockets(-)"
inherit php-ext-pecl-r3
@@ -18,14 +19,6 @@ KEYWORDS="~amd64 ~x86"
DESCRIPTION="Provides support for RADIUS authentication (RFC 2865) and accounting (RFC 2866)"
LICENSE="BSD"
SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
+IUSE="examples"
S="${PHP_EXT_S}"
-
-RDEPEND="
- php_targets_php7-2? ( dev-lang/php:7.2[pcntl(-),sockets(-)] )
- php_targets_php7-3? ( dev-lang/php:7.3[pcntl(-),sockets(-)] )
- php_targets_php7-4? ( dev-lang/php:7.4[pcntl(-),sockets(-)] )
-"
-DEPEND="test? ( ${RDEPEND} )"