summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-09 15:36:53 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-09 15:37:16 -0500
commite15257f921539f363bf06aa0ddcd352ce785787c (patch)
tree8b3620dccbac4a819d6a1e9b943b56477dbe6a5b /dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild
parentmedia-tv/kodi: Use cmake instead of autotools, bump to 17.0_rc2 (diff)
downloadgentoo-e15257f921539f363bf06aa0ddcd352ce785787c.tar.gz
gentoo-e15257f921539f363bf06aa0ddcd352ce785787c.tar.bz2
gentoo-e15257f921539f363bf06aa0ddcd352ce785787c.zip
dev-php/PEAR-XML_RSS: new version 1.1.0_alpha1.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild')
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild
new file mode 100644
index 000000000000..167ccf86a423
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/alpha/a}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="PHP parser for RDF and RSS documents"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# Only needs PEAR_Exception (not in the tree), not all of PEAR.
+# This can be made into an || dependency if we add PEAR_Exception.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-XML_Parser"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r XML
+}