summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-03 11:52:44 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-03 11:57:42 +1200
commit5309a5e467f69ec1d88c19a6f772ce5eb5f791b2 (patch)
tree54d74e8327b4fe74c3b2f6e434e377ef67e673f7 /dev-perl
parentdev-perl/Authen-PAM: -r bump for EAPI7 + CFLAGS love (diff)
downloadgentoo-5309a5e467f69ec1d88c19a6f772ce5eb5f791b2.tar.gz
gentoo-5309a5e467f69ec1d88c19a6f772ce5eb5f791b2.tar.bz2
gentoo-5309a5e467f69ec1d88c19a6f772ce5eb5f791b2.zip
dev-perl/autobox: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Ensure CFLAGS passed to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/autobox/autobox-3.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/autobox/autobox-3.0.1-r1.ebuild b/dev-perl/autobox/autobox-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..37acd5c19b97
--- /dev/null
+++ b/dev-perl/autobox/autobox-3.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=CHOCOLATE
+DIST_VERSION=v3.0.1
+inherit perl-module
+
+DESCRIPTION="Call methods on native types"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Scope-Guard-0.210.0
+ >=virtual/perl-version-0.770.0
+"
+BEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/IPC-System-Simple-1.250.0
+ >=dev-perl/Test-Fatal-0.14.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}