summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-28 20:06:55 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-28 20:07:32 +1300
commitdbd810acd7ca84e9359926edc54adf8172e89f12 (patch)
tree3592ebd2a474cc9890fc1f1e8789d8f5fa78e3e8 /dev-perl/XML-SAX
parentapp-portage/g-sorcery-0.2.1-r1: added ~mips, bug 524040 (diff)
downloadgentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.tar.gz
gentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.tar.bz2
gentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.zip
dev-perl/XML-SAX: Bump to version 1.0.0
- EAPI6 - Enable parallel tests - Rework auto-ini-generation removal logic as a patch - Cease using encodings.patch which now appears of little value ( was included as part of #127735 but the fix that fixed that issue is long upstreamed and tests indicate it no longer relevant ) Upstream: - Build order fixes for vanilla installs Bug: https://bugs.gentoo.org/127735 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-SAX')
-rw-r--r--dev-perl/XML-SAX/Manifest1
-rw-r--r--dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild44
-rw-r--r--dev-perl/XML-SAX/files/XML-SAX-1.00-noautoini.patch63
3 files changed, 108 insertions, 0 deletions
diff --git a/dev-perl/XML-SAX/Manifest b/dev-perl/XML-SAX/Manifest
index da7506dc31c5..4581e9fdbced 100644
--- a/dev-perl/XML-SAX/Manifest
+++ b/dev-perl/XML-SAX/Manifest
@@ -1 +1,2 @@
DIST XML-SAX-0.99.tar.gz 46703 BLAKE2B e31da35dceab72c9b2c1efc35e49e00c4693ed10991f59e4f5b228b4c4ddff912744c2a9bd867afe37bfd8f3c105a9c3674f0b6221f519fc00e64e246eb8671e SHA512 f0c55efee4e3010deb474377394f9635bd8adc50108b562aeef54a2eef312cf87fb240d0495b5a5bd0c4cd5251db1bc74ba6cb549614708b1627f330959735e1
+DIST XML-SAX-1.00.tar.gz 46808 BLAKE2B c81b42050c98d749f5c8e133733c6acc2576dd31d156c98370030c387baccfcbfafcce644152edab114062039ca1075ced38f079ab9c4876470a79549dc8caa1 SHA512 95553c9693d8a310747b4b86d4e80a58d4056b18cfc334f6979c98d0e9034a34253bfb17daecfc5bb28b1bd65e6baf52136f5135a969fadba86aa4148ea9bc1d
diff --git a/dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild b/dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild
new file mode 100644
index 000000000000..a6ecf0690138
--- /dev/null
+++ b/dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GRANTM
+DIST_VERSION=1.00
+inherit perl-module eutils
+
+DESCRIPTION="Perl module for using and building Perl SAX2 XML parsers, filters, and drivers"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/XML-SAX-Base-1.50.0
+ >=dev-perl/XML-NamespaceSupport-1.40.0
+ >=dev-libs/libxml2-2.4.1
+ virtual/perl-File-Temp
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=("${FILESDIR}/${PN}-1.00-noautoini.patch")
+
+pkg_postinst() {
+ pkg_update_parser add XML::SAX::PurePerl
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}
diff --git a/dev-perl/XML-SAX/files/XML-SAX-1.00-noautoini.patch b/dev-perl/XML-SAX/files/XML-SAX-1.00-noautoini.patch
new file mode 100644
index 000000000000..75ec799e17e8
--- /dev/null
+++ b/dev-perl/XML-SAX/files/XML-SAX-1.00-noautoini.patch
@@ -0,0 +1,63 @@
+From 69984a8dbd2553d5a3c504c0f945b955d243380f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 28 Mar 2018 19:48:34 +1300
+Subject: Remove all of the automatic INI generation code.
+
+As this will be handled by Gentoo outside the install phase anyway.
+
+Bug: https://bugs.gentoo.org/168988
+---
+ Makefile.PL | 40 ----------------------------------------
+ 1 file changed, 40 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index b0b09c7..78c5f3b 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -12,43 +12,3 @@ WriteMakefile(
+ 'XML::NamespaceSupport' => 0.03,
+ },
+ );
+-
+-sub MY::install {
+- package MY;
+- my $script = shift->SUPER::install(@_);
+-
+- # Only modify existing ParserDetails.ini if user agrees
+-
+- my $write_ini_ok = 0;
+-
+- eval { require XML::SAX };
+- if ($@) {
+- $write_ini_ok = 1;
+- }
+- else {
+- my $dir = File::Basename::dirname($INC{'XML/SAX.pm'});
+- if (-e File::Spec->catfile($dir, 'SAX', 'ParserDetails.ini')) {
+- $write_ini_ok =
+- ExtUtils::MakeMaker::prompt(
+- "Do you want XML::SAX to alter ParserDetails.ini?", "Y"
+- ) =~ /^y/i;
+- }
+- else {
+- $write_ini_ok = 1;
+- }
+- }
+-
+- if ($write_ini_ok) {
+- $script =~ s/install :: (.*)$/install :: $1 install_sax_pureperl/m;
+- $script .= <<"INSTALL";
+-
+-install_sax_pureperl : pure_install
+-\t\@\$(PERL) -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()"
+-
+-INSTALL
+-
+- }
+-
+- return $script;
+-}
+-
+--
+2.16.2
+