summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-09-05 19:50:59 +0300
committerSam James <sam@gentoo.org>2024-09-05 20:32:48 +0100
commitdf72bb6d4a18a552c6ef7d989bf477e56bb1109f (patch)
tree844b62ceb56cbeb020af7dcbb47d36adc96bbfb9 /dev-perl/Wx
parentnet-libs/nodejs: Stabilize 22.7.0 arm64, #939121 (diff)
downloadgentoo-df72bb6d4a18a552c6ef7d989bf477e56bb1109f.tar.gz
gentoo-df72bb6d4a18a552c6ef7d989bf477e56bb1109f.tar.bz2
gentoo-df72bb6d4a18a552c6ef7d989bf477e56bb1109f.zip
dev-perl/Wx: export CC as CXX due to xspp expectations
Previous eclass change modified behavior to explicitly set CC. This broke expectiations for xspp as Wx was setting CC to CXX in a weak way. https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3a650e223a09b0616a4e619c73cc033478fb7a61 https://metacpan.org/release/MDOOTSON/Wx-0.9932/source/build/Wx/build/MakeMaker/Any_wx_config.pm#L27 Closes: https://bugs.gentoo.org/931939 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Wx')
-rw-r--r--dev-perl/Wx/Wx-0.993.200-r3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-perl/Wx/Wx-0.993.200-r3.ebuild b/dev-perl/Wx/Wx-0.993.200-r3.ebuild
index 9c2559675aa1..e2efd5f8250a 100644
--- a/dev-perl/Wx/Wx-0.993.200-r3.ebuild
+++ b/dev-perl/Wx/Wx-0.993.200-r3.ebuild
@@ -7,7 +7,7 @@ WX_GTK_VER="3.2-gtk3"
DIST_AUTHOR=MDOOTSON
DIST_VERSION=0.9932
DIST_EXAMPLES=("samples/*")
-inherit wxwidgets virtualx perl-module
+inherit toolchain-funcs wxwidgets virtualx perl-module
DESCRIPTION="Perl bindings for wxGTK"
HOMEPAGE="https://wxperl.sourceforge.net/ https://metacpan.org/release/Wx"
@@ -54,6 +54,13 @@ src_prepare() {
perl-module_src_prepare
}
+src_configure() {
+ # xspp sets CC to a c++ compiler but the eclass overrides it
+ # https://bugs.gentoo.org/931939
+ export CC="$(tc-getCXX)"
+ perl-module_src_configure
+}
+
src_test() {
# the webview/t/03_threads.t test tends to hang or crash in weird
# ways depending on local configuration. eg, backtraces involving