summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-14 05:10:49 +0100
committerSam James <sam@gentoo.org>2024-10-14 05:17:41 +0100
commit502e2c677fe7117bf60fe58f964d6493dcf76ada (patch)
tree2161b04ec028308082759d02e3ac7d5e3720c0f7 /dev-perl/Type-Tiny
parentdev-perl/PDL: add 2.93.0 (diff)
downloadgentoo-502e2c677fe7117bf60fe58f964d6493dcf76ada.tar.gz
gentoo-502e2c677fe7117bf60fe58f964d6493dcf76ada.tar.bz2
gentoo-502e2c677fe7117bf60fe58f964d6493dcf76ada.zip
dev-perl/Type-Tiny: add 2.6.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Type-Tiny')
-rw-r--r--dev-perl/Type-Tiny/Manifest1
-rw-r--r--dev-perl/Type-Tiny/Type-Tiny-2.6.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Type-Tiny/Manifest b/dev-perl/Type-Tiny/Manifest
index 1829fb45b735..4f07915de866 100644
--- a/dev-perl/Type-Tiny/Manifest
+++ b/dev-perl/Type-Tiny/Manifest
@@ -1 +1,2 @@
DIST Type-Tiny-2.004000.tar.gz 470299 BLAKE2B 0155f2e67a545365f6db2d1c6a309501407f1f2b3ea2b334be73c4557c8fabf9f8765f92cdd9eba2ef0063de39569f0989106e09b92505889d7099c4b7ef3743 SHA512 a28a0fdfe48c8ce7f7313bfa6645094337dfb12d76401d9947a649763379a912f480ff418f0023d1e0c5851ffa347823669192a9eb8081341db7525d84c82220
+DIST Type-Tiny-2.006000.tar.gz 477845 BLAKE2B 51b0552c689806f863e5084c78b5425cea2bb40c0a3b86bb0927524d80ab5f27df2188395b176dcdb35d2ff579b492c3f80e9b468bd8b2c7986bc81d044ec27f SHA512 24c3fea4834eb093b2aceff82e951bed73adf821d77c0f5445085021b8dc661cc3264198d265817349e582fc0e640303534a1d23ae1fcf669135ed7ab3ee937d
diff --git a/dev-perl/Type-Tiny/Type-Tiny-2.6.0.ebuild b/dev-perl/Type-Tiny/Type-Tiny-2.6.0.ebuild
new file mode 100644
index 000000000000..44ca38e06eb0
--- /dev/null
+++ b/dev-perl/Type-Tiny/Type-Tiny-2.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=2.006000
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Tiny, yet Moo(se)-compatible type constraint"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="minimal"
+
+RDEPEND="
+ !<dev-perl/Kavorka-0.13.0
+ !<dev-perl/Types-ReadOnly-0.1.0
+ !dev-perl/Type-Tie
+ >=dev-perl/Exporter-Tiny-1.4.1
+ >=virtual/perl-Test-Simple-1.1.10
+ !minimal? (
+ >=dev-perl/Class-XSAccessor-1.170.0
+ >=dev-perl/Devel-LexAlias-0.50.0
+ dev-perl/Devel-StackTrace
+ >=dev-perl/Ref-Util-XS-0.100.0
+ >=dev-perl/Regexp-Util-0.3.0
+ virtual/perl-Scalar-List-Utils
+ )
+"
+PDEPEND="
+ !minimal? (
+ >=dev-perl/Type-Tiny-XS-0.25.0
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ >=virtual/perl-CPAN-Meta-Requirements-2.0.0
+ test? (
+ dev-perl/Test-Warnings
+ )
+"