summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-26 20:09:46 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:08 +1300
commit713c9226f90553c27ab841c56888a1f50ded5925 (patch)
treea7a82bffc3bd5d20bd5ef2441ceeec31219d605d /dev-perl/Parse-ErrorString-Perl
parentdev-perl/Params-ValidationCompiler: Bump to version 0.260.0 (diff)
downloadgentoo-713c9226f90553c27ab841c56888a1f50ded5925.tar.gz
gentoo-713c9226f90553c27ab841c56888a1f50ded5925.tar.bz2
gentoo-713c9226f90553c27ab841c56888a1f50ded5925.zip
dev-perl/Parse-ErrorString-Perl: Bump to version 0.270.0
- Patchify Perl 5.26 fix Upstream: - Documentation fixes - Remove unreachable code Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Parse-ErrorString-Perl')
-rw-r--r--dev-perl/Parse-ErrorString-Perl/Manifest1
-rw-r--r--dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild30
-rw-r--r--dev-perl/Parse-ErrorString-Perl/files/Parse-ErrorString-Perl-0.27-no-dot-inc.patch25
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/Parse-ErrorString-Perl/Manifest b/dev-perl/Parse-ErrorString-Perl/Manifest
index db684f1e2f67..c966a9b0fd4c 100644
--- a/dev-perl/Parse-ErrorString-Perl/Manifest
+++ b/dev-perl/Parse-ErrorString-Perl/Manifest
@@ -1 +1,2 @@
DIST Parse-ErrorString-Perl-0.22.tar.gz 29675 BLAKE2B bbb8043ba24f5bdc7f2ceb741757dafa32f577876199418c2162ad56eef32975c8a153b1941d0d8ba6983eb881bcde199379a1cb18d276d1c8d611951bd3e231 SHA512 a1a99a876cd575adfcd30a3f73ed23c104380b32e24f34fc135b315794c640a37369abe10aea0daa5a73da030a38b52439b4a4716cc3c2c5a610a524a9ced507
+DIST Parse-ErrorString-Perl-0.27.tar.gz 29698 BLAKE2B fc1743382145c40a44de21f9a48d302fbb5f80f583b8545553507ef892baebb4f879649e1ccc0e511ffe3d986184397c8933ccd40999966be3154785b1b0004a SHA512 2111d3d130e7eeb754e11d6a20cd289be888fd384853d19000820363b8a2bb60f75db029cbf6646ec267ba5a9f25ddc596c335c41623cc07a82b12fce81a9800
diff --git a/dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild b/dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild
new file mode 100644
index 000000000000..a2b8e197eb18
--- /dev/null
+++ b/dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Parse error messages from the perl interpreter"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-XSAccessor
+ virtual/perl-File-Spec
+ virtual/perl-Pod-Parser
+ >=dev-perl/Pod-POM-0.270.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.59
+ test? (
+ dev-perl/Test-Differences
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+PATCHES=( "${FILESDIR}/${PN}-0.27-no-dot-inc.patch" )
diff --git a/dev-perl/Parse-ErrorString-Perl/files/Parse-ErrorString-Perl-0.27-no-dot-inc.patch b/dev-perl/Parse-ErrorString-Perl/files/Parse-ErrorString-Perl-0.27-no-dot-inc.patch
new file mode 100644
index 000000000000..1fd431da93f8
--- /dev/null
+++ b/dev-perl/Parse-ErrorString-Perl/files/Parse-ErrorString-Perl-0.27-no-dot-inc.patch
@@ -0,0 +1,25 @@
+From ef3a6362d55a02572b55d8f56cccb1beaa873097 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Tue, 4 Jul 2017 09:17:29 +1200
+Subject: Add build fixx for Perl 5.26
+
+Bug: https://bugs.gentoo.org/623086
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 86e91c4..091130b 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,6 @@
+ use strict;
+ use warnings;
+-use inc::Module::Install;
++use lib q[.]; use inc::Module::Install;
+
+ name 'Parse-ErrorString-Perl';
+ license 'perl';
+--
+2.15.1
+