summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-10-11 16:55:12 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-11 16:55:12 +0200
commit01b6ba27138cc837e8db92dfb7dc17b35790b060 (patch)
treefd73ba90ad5b1f7a8a1b79fdd41f7150619e43f7 /dev-perl/Gtk3-ImageView/Gtk3-ImageView-10.0.0.ebuild
parentsci-libs/htslib: drop 1.10.2 (diff)
downloadgentoo-01b6ba27138cc837e8db92dfb7dc17b35790b060.tar.gz
gentoo-01b6ba27138cc837e8db92dfb7dc17b35790b060.tar.bz2
gentoo-01b6ba27138cc837e8db92dfb7dc17b35790b060.zip
dev-perl/Gtk3-ImageView: version bump 10
Closes: https://github.com/gentoo/gentoo/pull/22474 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-perl/Gtk3-ImageView/Gtk3-ImageView-10.0.0.ebuild')
-rw-r--r--dev-perl/Gtk3-ImageView/Gtk3-ImageView-10.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Gtk3-ImageView/Gtk3-ImageView-10.0.0.ebuild b/dev-perl/Gtk3-ImageView/Gtk3-ImageView-10.0.0.ebuild
new file mode 100644
index 000000000000..b9b1a3df6014
--- /dev/null
+++ b/dev-perl/Gtk3-ImageView/Gtk3-ImageView-10.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ASOKOLOV
+DIST_VERSION=10
+DIST_TEST=do
+inherit perl-module virtualx
+
+DESCRIPTION="Image viewer widget for Gtk3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Cairo
+ >=dev-perl/glib-perl-1.210.0
+ dev-perl/Gtk3
+ dev-perl/Readonly
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Carp-Always
+ dev-perl/Test-Differences
+ dev-perl/Test-MockObject
+ dev-perl/Try-Tiny
+ media-gfx/imagemagick[jpeg,perl,png,svg,X]
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/90_MANIFEST.t
+ t/91_critic.t
+)
+
+src_test() {
+ virtx perl-module_src_test
+}