summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-26 20:08:47 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-26 20:12:31 +1200
commiteb7c766d558da864d316415925275ff8c44f00bd (patch)
treecc6202a6f62729eb09d5f9a00c7cde445d5dbc96 /dev-perl/DateTime-Format-SQLite
parentmail-mta/notqmail[qmail-spp]: fix build (diff)
downloadgentoo-eb7c766d558da864d316415925275ff8c44f00bd.tar.gz
gentoo-eb7c766d558da864d316415925275ff8c44f00bd.tar.bz2
gentoo-eb7c766d558da864d316415925275ff8c44f00bd.zip
dev-perl/DateTime-Format-SQLite: -r bump for EAPI7
- EAPI7 - Parallel tests - Remove bad tests unconditionally - Ensure DBD-SQLite installed for testing Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DateTime-Format-SQLite')
-rw-r--r--dev-perl/DateTime-Format-SQLite/DateTime-Format-SQLite-0.110.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-SQLite/DateTime-Format-SQLite-0.110.0-r1.ebuild b/dev-perl/DateTime-Format-SQLite/DateTime-Format-SQLite-0.110.0-r1.ebuild
new file mode 100644
index 000000000000..08bad08589e7
--- /dev/null
+++ b/dev-perl/DateTime-Format-SQLite/DateTime-Format-SQLite-0.110.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CFAERBER
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="Parse and format SQLite dates and times"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/DateTime-0.51
+ >=dev-perl/DateTime-Format-Builder-0.79.01
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/DBD-SQLite
+ )
+"
+PERL_RM_FILES=(
+ t/10pod.t
+ t/11pod_cover.t
+)