summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 02:51:07 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 02:53:04 +1200
commit62b5113895cfdf27106de25195aa25f8214ddd82 (patch)
tree4e1296648149cb3cc2273490f0f35dbcd2b54b4f /dev-perl/Crypt-Curve25519
parentapp-office/libalkimia: 8.0.3 version bump (diff)
downloadgentoo-62b5113895cfdf27106de25195aa25f8214ddd82.tar.gz
gentoo-62b5113895cfdf27106de25195aa25f8214ddd82.tar.bz2
gentoo-62b5113895cfdf27106de25195aa25f8214ddd82.zip
dev-perl/Crypt-Curve25519: -r bump for EAPI7 and fixes
- EAPI7 - Fix license ( Used CC-PD, as some parts say they're public-domain works, but there's not really a better license for this at present ), and some parts have 3-clause BSD. - Ensure CFLAGS passed through to make - Make PATCHES a bash array Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-Curve25519')
-rw-r--r--dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild b/dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild
new file mode 100644
index 000000000000..320adc25a9cc
--- /dev/null
+++ b/dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AJGB
+DIST_VERSION=0.06
+inherit perl-module flag-o-matic
+
+DESCRIPTION="Shared secret elliptic-curve Diffie-Hellman generator"
+LICENSE="|| ( Artistic GPL-1+ ) BSD CC-PD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fmul-fixedvar.patch"
+)
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}