summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-04 17:08:35 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-04 17:08:35 +0200
commitbf7f92a01ec0c0304d5ef7fd3d35c25cea4e6fdd (patch)
treea6bd8779dcc79a076cb11e03b7dd8a5b97ee03c2 /dev-ml
parentapp-emacs/parsebib: bump to 4.1 (diff)
downloadgentoo-bf7f92a01ec0c0304d5ef7fd3d35c25cea4e6fdd.tar.gz
gentoo-bf7f92a01ec0c0304d5ef7fd3d35c25cea4e6fdd.tar.bz2
gentoo-bf7f92a01ec0c0304d5ef7fd3d35c25cea4e6fdd.zip
dev-ml/utop: enable Emacs support
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/utop/files/50utop-gentoo.el3
-rw-r--r--dev-ml/utop/utop-2.8.0-r1.ebuild63
-rw-r--r--dev-ml/utop/utop-2.8.0.ebuild27
-rw-r--r--dev-ml/utop/utop-2.9.0-r1.ebuild63
-rw-r--r--dev-ml/utop/utop-2.9.0.ebuild27
-rw-r--r--dev-ml/utop/utop-2.9.1-r1.ebuild63
-rw-r--r--dev-ml/utop/utop-2.9.1.ebuild27
7 files changed, 192 insertions, 81 deletions
diff --git a/dev-ml/utop/files/50utop-gentoo.el b/dev-ml/utop/files/50utop-gentoo.el
new file mode 100644
index 000000000000..958c8398e602
--- /dev/null
+++ b/dev-ml/utop/files/50utop-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'utop "utop"
+ "A universal toplevel for OCaml." t)
diff --git a/dev-ml/utop/utop-2.8.0-r1.ebuild b/dev-ml/utop/utop-2.8.0-r1.ebuild
new file mode 100644
index 000000000000..cd05e5fc7a0c
--- /dev/null
+++ b/dev-ml/utop/utop-2.8.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-ml/utop/utop-2.8.0.ebuild b/dev-ml/utop/utop-2.8.0.ebuild
deleted file mode 100644
index d5b493a8c2cf..000000000000
--- a/dev-ml/utop/utop-2.8.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit dune
-
-DESCRIPTION="Universal toplevel for OCaml"
-HOMEPAGE="https://github.com/ocaml-community/utop"
-SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
-
-RDEPEND="
- dev-ml/camomile:=
- dev-ml/lambda-term:=
- dev-ml/lwt:=
- dev-ml/react:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-ml/cppo
- dev-ml/findlib
-"
diff --git a/dev-ml/utop/utop-2.9.0-r1.ebuild b/dev-ml/utop/utop-2.9.0-r1.ebuild
new file mode 100644
index 000000000000..cd05e5fc7a0c
--- /dev/null
+++ b/dev-ml/utop/utop-2.9.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-ml/utop/utop-2.9.0.ebuild b/dev-ml/utop/utop-2.9.0.ebuild
deleted file mode 100644
index d5b493a8c2cf..000000000000
--- a/dev-ml/utop/utop-2.9.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit dune
-
-DESCRIPTION="Universal toplevel for OCaml"
-HOMEPAGE="https://github.com/ocaml-community/utop"
-SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
-
-RDEPEND="
- dev-ml/camomile:=
- dev-ml/lambda-term:=
- dev-ml/lwt:=
- dev-ml/react:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-ml/cppo
- dev-ml/findlib
-"
diff --git a/dev-ml/utop/utop-2.9.1-r1.ebuild b/dev-ml/utop/utop-2.9.1-r1.ebuild
new file mode 100644
index 000000000000..cd05e5fc7a0c
--- /dev/null
+++ b/dev-ml/utop/utop-2.9.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-ml/utop/utop-2.9.1.ebuild b/dev-ml/utop/utop-2.9.1.ebuild
deleted file mode 100644
index 55ec4f6fd152..000000000000
--- a/dev-ml/utop/utop-2.9.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit dune
-
-DESCRIPTION="Universal toplevel for OCaml"
-HOMEPAGE="https://github.com/ocaml-community/utop"
-SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
-
-RDEPEND="
- dev-ml/camomile:=
- dev-ml/lambda-term:=
- dev-ml/lwt:=
- dev-ml/react:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-ml/cppo
- dev-ml/findlib
-"