summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-09 09:31:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-09 09:31:59 +0200
commitafa2872bfae8a6f470e05a4f59eda19d87288e55 (patch)
tree690f183729d2cb47b5ddab06b5dd47ade786a401 /dev-ml
parentsys-apps/polychromatic: bump to 0.8.2 (diff)
downloadgentoo-afa2872bfae8a6f470e05a4f59eda19d87288e55.tar.gz
gentoo-afa2872bfae8a6f470e05a4f59eda19d87288e55.tar.bz2
gentoo-afa2872bfae8a6f470e05a4f59eda19d87288e55.zip
dev-ml/merlin: bump to 4.12
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/merlin/Manifest1
-rw-r--r--dev-ml/merlin/merlin-4.12.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-ml/merlin/Manifest b/dev-ml/merlin/Manifest
index 12f69e065f7d..10a6fa3f5697 100644
--- a/dev-ml/merlin/Manifest
+++ b/dev-ml/merlin/Manifest
@@ -1,4 +1,5 @@
DIST merlin-4.10-414.tbz 1989927 BLAKE2B 9a65e9c1a2d5795e1e0235d5c8b0274bd9d8ef052ed421e8809224de73f577da273c9f1ca0f071d6ea0accd349b9b6d59b2e1fb5561effe483ebb0de89a4c766 SHA512 7805b99c2a73b2e3f70d26fd7183a90f97657d66946e2a4b58563f00fd3ed8d82da1fb0597b033b8c8c9e8db415d66e51720c972d34db4b66b71bb8f0c9ee08c
+DIST merlin-4.12-414.tbz 1991877 BLAKE2B d68a45efb29d7ed2dd8d2e377a7778fad5500064206e5ae27914a0be9f208f919f44f73f14be283aca653adf56462a782c4f5f895282e078478e60f13e9c09f1 SHA512 3bf4f5e4754def9818ce0abbdf2253fe9d5e0abec7e8814012e2ff9de6a174f288c257780eb9f8aa4d794c0b62a524848d579d2a3495a5747a0970ee9fbfff29
DIST merlin-4.7-412.tbz 1771126 BLAKE2B 1454873ecc1d533a5e82adaa71082339c44b93c2626d46cc5147d1b8049b397ef34e6137256560d6c9b7eaf826155e34617c071d1aae3aa3f02807e73c209cf1 SHA512 d13e307d87b4719b56397e54e6f771a3ea77a766ab38b22414c4b1d4d5828b5f790c82f28d3feaf7fe45be10abd50d9a905ece932f43fdad98c88b73b35dd936
DIST merlin-4.7-413.tbz 2296558 BLAKE2B 2e6d9918c911eab017bb3491cab97f2b0362d13e072a0c39a6637f25d2a15ac7f3027cec51ab0d66a2239fea055f70b5b1e3294c05985faae5d11c57bff81501 SHA512 71068a6b50628c57003b29de3968e41c24b67394dcc1d1f1a0b335211e9d1ef3e527584b868514bd5489db5a130f2ff6fd145d3665a7d2bca5a117074cb08ce8
DIST merlin-4.7-414.tbz 1976276 BLAKE2B 91fc5221b536d20174e36c4fdf4bc32f125f2af0f23c95c2e917f425826b0c58fe65b1b849eded570b8f4aece0fb00f1bdf7d0a00fa67f6c4e58892a095e1466 SHA512 c325c29bea91699739d7cb7df12876b7ffb8edf685deabb5dce5553b570a6bf8ff415c45e3295b674edbc7711f69f4be202b866d157516380f888e80dcee1082
diff --git a/dev-ml/merlin/merlin-4.12.ebuild b/dev-ml/merlin/merlin-4.12.ebuild
new file mode 100644
index 000000000000..3e4435149b42
--- /dev/null
+++ b/dev-ml/merlin/merlin-4.12.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: vim-plugin, although it's not clear how to make it work here
+inherit elisp-common dune
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin/"
+SRC_URI="https://github.com/ocaml/merlin/releases/download/v${PV}-414/${P}-414.tbz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="emacs +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/csexp:=
+ >=dev-ml/yojson-2.0.0:=
+ dev-ml/menhir:=
+ >=dev-ml/dune-2.9:=
+ || (
+ dev-lang/ocaml:0/4.14
+ dev-lang/ocaml:0/4.14.1
+ )
+ emacs? (
+ >=app-editors/emacs-23.1:*
+ app-emacs/auto-complete
+ app-emacs/company-mode
+ )
+"
+DEPEND="${RDEPEND}"
+# NOTICE: Block dev-ml/seq (which is a back-port of code to ocaml <4.07)
+# because it breaks merlin builds.
+# https://github.com/ocaml/merlin/issues/1500
+BDEPEND="
+ !!<dev-ml/seq-0.3
+ test? ( app-misc/jq )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ default
+
+ if has_version "dev-lang/ocaml:0/4.14" ; then
+ mv ${P}-414 "${S}" || die
+ elif has_version "dev-lang/ocaml:0/4.14.1" ; then
+ mv ${P}-414 "${S}" || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Handle ELisp installation via the Emacs Eclass.
+ rm emacs/dune || die
+
+ # This test runs only inside a git repo,
+ # it is not included in merlin release for ocaml 4.12.
+ if [[ -f tests/test-dirs/occurrences/issue1404.t ]] ; then
+ rm tests/test-dirs/occurrences/issue1404.t || die
+ fi
+ rm -r tests/test-dirs/locate/context-detection/cd-mod_constr.t || die
+
+ # Remove seq references from dune build files.
+ sed -i 's|seq||g' src/frontend/ocamlmerlin/dune || die
+}
+
+src_compile() {
+ edune build @install
+
+ if use emacs ; then
+ # iedit isn't packaged yet
+ rm emacs/merlin-iedit.el || die
+
+ BYTECOMPFLAGS="-L emacs" elisp-compile emacs/*.el
+ fi
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}