summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-21 20:12:54 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-21 20:13:26 +0100
commit668947c60b174a71cb9cbc954da54a4a16c4db64 (patch)
tree177c694c13707746af6957b72af12b045c37b9bd /dev-ml
parentdev-python/sphinx-copybutton: Stabilize 0.5.2 x86, #943616 (diff)
downloadgentoo-668947c60b174a71cb9cbc954da54a4a16c4db64.tar.gz
gentoo-668947c60b174a71cb9cbc954da54a4a16c4db64.tar.bz2
gentoo-668947c60b174a71cb9cbc954da54a4a16c4db64.zip
dev-ml/opam-common: new package, add 2.2.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-common/Manifest1
-rw-r--r--dev-ml/opam-common/metadata.xml11
-rw-r--r--dev-ml/opam-common/opam-common-2.2.1.ebuild43
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/opam-common/Manifest b/dev-ml/opam-common/Manifest
new file mode 100644
index 000000000000..3a42235d1748
--- /dev/null
+++ b/dev-ml/opam-common/Manifest
@@ -0,0 +1 @@
+DIST opam-2.2.1.tar.gz 1089671 BLAKE2B cd6a97c8c19d7866205b49f95bf4215d986b3ad8b5d1fe5c5fd52db9b8b9e0cff8559d478e18d99d89816bbf830910f182e4c1e80719ac29a3cd5c8299450a21 SHA512 17d7d83b9de118332c121b9d3aa2e48f62a6270ea23e730a536b0f4ff060df85238c7c4ab53a89bcc3b3193d52d14358831bd9bed30a4ac699e44e4c3003b8b0
diff --git a/dev-ml/opam-common/metadata.xml b/dev-ml/opam-common/metadata.xml
new file mode 100644
index 000000000000..8ee8dbb51969
--- /dev/null
+++ b/dev-ml/opam-common/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-common/opam-common-2.2.1.ebuild b/dev-ml/opam-common/opam-common-2.2.1.ebuild
new file mode 100644
index 000000000000..155f1bfdec12
--- /dev/null
+++ b/dev-ml/opam-common/opam-common-2.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+RESTRICT="test" #sandbox not working
+
+RDEPEND="
+ dev-ml/jsonm:=[ocamlopt?]
+ dev-ml/ocamlgraph:=[ocamlopt?]
+ dev-ml/ocaml-sha:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/swhid_core:=[ocamlopt?]
+ dev-ml/uchar:=[ocamlopt?]
+ dev-ml/uutf:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile opam-core opam-format
+}
+
+src_install() {
+ dune-install opam-core opam-format
+}