summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-16 10:47:26 +1100
committerMark Wright <gienah@gentoo.org>2020-10-16 10:47:26 +1100
commitb4789ff13c629a72b724707bdc794f6c9259c581 (patch)
treefce0b1e92453cc6115d37c2da761b0ac39894ac9 /dev-ml/ocamlbuild
parentdev-python/pyroute2: 0.5.14 bump (diff)
downloadgentoo-b4789ff13c629a72b724707bdc794f6c9259c581.tar.gz
gentoo-b4789ff13c629a72b724707bdc794f6c9259c581.tar.bz2
gentoo-b4789ff13c629a72b724707bdc794f6c9259c581.zip
dev-ml/ocamlbuild: Fix tests #705052
Thanks to tka for reporting. Closes: https://bugs.gentoo.org/705052 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlbuild')
-rw-r--r--dev-ml/ocamlbuild/files/ocamlbuild-0.14.0-Disable-tests-failing-with-OCaml-4.08.0.patch39
-rw-r--r--dev-ml/ocamlbuild/metadata.xml5
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild40
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild6
4 files changed, 89 insertions, 1 deletions
diff --git a/dev-ml/ocamlbuild/files/ocamlbuild-0.14.0-Disable-tests-failing-with-OCaml-4.08.0.patch b/dev-ml/ocamlbuild/files/ocamlbuild-0.14.0-Disable-tests-failing-with-OCaml-4.08.0.patch
new file mode 100644
index 000000000000..991f13238c05
--- /dev/null
+++ b/dev-ml/ocamlbuild/files/ocamlbuild-0.14.0-Disable-tests-failing-with-OCaml-4.08.0.patch
@@ -0,0 +1,39 @@
+From: Stephane Glondu <steph@glondu.net>
+Date: Fri, 2 Aug 2019 13:08:55 +0200
+Subject: Disable tests failing with OCaml 4.08.0
+
+---
+ testsuite/internal.ml | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/testsuite/internal.ml b/testsuite/internal.ml
+index d3c2004..a87f5e2 100644
+--- a/testsuite/internal.ml
++++ b/testsuite/internal.ml
+@@ -200,7 +200,7 @@ let () =
+ "]
+ ~targets:("src/foo.cmxs",[]) ();;
+
+-let () = test "StrictSequenceFlag"
++let _ignored () = test "StrictSequenceFlag"
+ ~options:[`no_ocamlfind; `quiet]
+ ~description:"strict_sequence tag"
+ ~tree:[T.f "hello.ml" ~content:"let () = 1; ()";
+@@ -219,7 +219,7 @@ Command exited with code 2."
+ )
+ ~targets:("hello.byte",[]) ();;
+
+-let () = test "StrictFormatsFlag"
++let _ignored () = test "StrictFormatsFlag"
+ ~options:[`no_ocamlfind; `quiet]
+ ~description:"strict_format tag"
+ ~tree:[T.f "hello.ml" ~content:"let _ = Printf.printf \"%.10s\"";
+@@ -230,7 +230,7 @@ Error: invalid format \"%.10s\": at character number 0, \
+ Command exited with code 2."
+ ~targets:("hello.byte",[]) ();;
+
+-let () = test "PrincipalFlag"
++let _ignored () = test "PrincipalFlag"
+ ~options:[`no_ocamlfind; `quiet]
+ ~description:"-principal tag"
+ ~tree:[T.f "hello.ml"
diff --git a/dev-ml/ocamlbuild/metadata.xml b/dev-ml/ocamlbuild/metadata.xml
index 4b8b15880263..234a45293e62 100644
--- a/dev-ml/ocamlbuild/metadata.xml
+++ b/dev-ml/ocamlbuild/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
<upstream>
<remote-id type="github">ocaml/ocamlbuild</remote-id>
</upstream>
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..087fc3e4f55c
--- /dev/null
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-ml/findlib-1.6.1-r1
+"
+DEPEND="${DEPEND}
+ test? ( dev-ml/findlib )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.14.0-Disable-tests-failing-with-OCaml-4.08.0.patch
+ )
+
+src_configure() {
+ emake -f configure.make Makefile.config \
+ PREFIX="${EPREFIX}/usr" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="$(ocamlc -where)" \
+ OCAML_NATIVE=$(usex ocamlopt true false) \
+ OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+ NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_install() {
+ emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+ dodoc Changes
+}
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
index ea186cfb10a6..913b9be0fc9c 100644
--- a/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
@@ -3,6 +3,8 @@
EAPI=5
+inherit eutils
+
DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
HOMEPAGE="https://github.com/ocaml/ocamlbuild"
SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -20,6 +22,10 @@ RDEPEND="${DEPEND}
DEPEND="${DEPEND}
test? ( dev-ml/findlib )"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.14.0-Disable-tests-failing-with-OCaml-4.08.0.patch
+}
+
src_configure() {
emake -f configure.make Makefile.config \
PREFIX="${EPREFIX}/usr" \