summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-08 20:33:14 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-08 20:34:32 +0200
commitb15f7464f711d820af66ba1321e14dab31caeb07 (patch)
tree207efb1330213fca02722aa929c9e3bcf132b2cc /dev-ml/ocaml_intrinsics
parentapp-misc/gojq: new package, add 0.12.16 (diff)
downloadgentoo-b15f7464f711d820af66ba1321e14dab31caeb07.tar.gz
gentoo-b15f7464f711d820af66ba1321e14dab31caeb07.tar.bz2
gentoo-b15f7464f711d820af66ba1321e14dab31caeb07.zip
dev-ml/ocaml_intrinsics: add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml_intrinsics')
-rw-r--r--dev-ml/ocaml_intrinsics/Manifest1
-rw-r--r--dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.17.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml_intrinsics/Manifest b/dev-ml/ocaml_intrinsics/Manifest
index 76ee115558d3..3d8b10bab654 100644
--- a/dev-ml/ocaml_intrinsics/Manifest
+++ b/dev-ml/ocaml_intrinsics/Manifest
@@ -1,3 +1,4 @@
DIST ocaml_intrinsics-0.15.1.tar.gz 24925 BLAKE2B 15d74ee891aced288aa734ef4d70a4816f2d2725d0d445620154bec7d1667d3ac06c5ddd778777d15858cbf198ecd978b22959fe68e159ddd9dbbd32304c3077 SHA512 cb0ac26bc34c97eb0429e6833342dbd9fca6f1f4a40b8121f9e6364bd2cdc40676a164d7405454727ced9a4455adb0e3cac5118beb7ab70206adbd3e7f7937e2
DIST ocaml_intrinsics-0.15.2.tar.gz 24977 BLAKE2B eea2af5ff746cfd7b483df47a8f719c623eecc8bf82d852ed69395752e98ebb94a555ef2dd95271d45941a5582f7ff139f8e79d5dd8adf5389786aff756df7fe SHA512 21539fecd8b40420bdb45a3fe79f65cf4ff0deb103c3cb2b28bad24fddce159bdfab3f7aa6ade0028bebef1602f860b1f6cdf2cc06db1a89e232b221d8ff592b
DIST ocaml_intrinsics-0.16.0.tar.gz 35876 BLAKE2B fc9ead65244efe96ea130426265acb2cccc08105e53383ddfd7117bca461e28095f213f22dddafc1e3f6490ad2b4f0d4e9129a8dcf8dc207269ca83eb889acee SHA512 86bf6ac7cb1da5de03224cc053e174ec22af766b6c5ab4ca1fde3c028405858cb97feeae6968d9054a7d6994491b9f2cdb8e198ee837ad4242f9cd812873ceaa
+DIST ocaml_intrinsics-0.17.0.tar.gz 32720 BLAKE2B db536481d58851dbb96a1dc9070cc680fd558279c88ddce0176d168660be6dc8ee1bb7b67f877132163077c96773dad4b4c36c25db664511e833e0d5563ef4f9 SHA512 c5846c2ff163ad7d4dd3b22caa78dc5bb6e83ae4abc497a1ed10bb08b13f6b0f16e8447d47e947531ecafb27cdd65589b338f214b8dce44f5f8f47a1f0616ba2
diff --git a/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.17.0.ebuild b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.17.0.ebuild
new file mode 100644
index 000000000000..bfa5f4787b36
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.17.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Invoke amd64 instructions (such as clz, popcnt, rdtsc, rdpmc)"
+HOMEPAGE="https://github.com/janestreet/ocaml_intrinsics/"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+DEPEND="
+ dev-ml/dune-configurator:=
+ dev-ml/ocaml_intrinsics_kernel:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-lang/ocaml-4.12
+ >=dev-ml/dune-3.11
+"