summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/fort
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/fort')
-rw-r--r--dev-ml/fort/Manifest1
-rw-r--r--dev-ml/fort/files/fort-0.4.2-ocaml4.patch22
-rw-r--r--dev-ml/fort/fort-0.4.2.ebuild30
-rw-r--r--dev-ml/fort/metadata.xml15
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-ml/fort/Manifest b/dev-ml/fort/Manifest
new file mode 100644
index 000000000000..91cc92a912cc
--- /dev/null
+++ b/dev-ml/fort/Manifest
@@ -0,0 +1 @@
+DIST fort-0.4.2.tar.gz 6828 SHA256 171ddc85901f897cd1c47d6ef04f16b011673cd0f06e7d57cfa95688879192e7 SHA512 59659bcc885f8d71985121a2abcfef756078eb472cadbd74ff97aef3378cd3f2a2a6da3a41a0a015b3175c18d98775e7f6b26c7a76262eb044b25122679c15a8 WHIRLPOOL 980a10c89b3734fd4e5ed9ae42b5ab80deffb545a6b06aec4385a7389bcfb6eb01b9c1dbe8affb0fe3280a552f2dda1c7560b8abc9490e0a447d43f2d07ca433
diff --git a/dev-ml/fort/files/fort-0.4.2-ocaml4.patch b/dev-ml/fort/files/fort-0.4.2-ocaml4.patch
new file mode 100644
index 000000000000..1c688a995446
--- /dev/null
+++ b/dev-ml/fort/files/fort-0.4.2-ocaml4.patch
@@ -0,0 +1,22 @@
+Index: fort-0.4.2/Makefile
+===================================================================
+--- fort-0.4.2.orig/Makefile
++++ fort-0.4.2/Makefile
+@@ -3,7 +3,7 @@
+
+ include Makefile.config
+
+-OCAMLC := ocamlc
++OCAMLC := ocamlc -I +compiler-libs
+
+ # FORT top-level interpreter
+ NAME := fort
+@@ -16,7 +16,7 @@ LIBS := unix
+ EXECUTABLE := $(NAME)$(EXEC_SUFFIX)
+
+ $(EXECUTABLE): $(OBJECTS)
+- $(OCAMLC) -linkall -o $@ toplevellib.cma $(LIBS:%=%.cma) $(OBJECTS)
++ $(OCAMLC) -linkall -o $@ ocamlcommon.cma ocamlbytecomp.cma ocamltoplevel.cma $(LIBS:%=%.cma) $(OBJECTS)
+
+ install: $(EXECUTABLE) $(OBJECTS)
+ mkdir -p $(DESTDIR)$(LIBDIR)
diff --git a/dev-ml/fort/fort-0.4.2.ebuild b/dev-ml/fort/fort-0.4.2.ebuild
new file mode 100644
index 000000000000..46def158dcbe
--- /dev/null
+++ b/dev-ml/fort/fort-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib eutils
+
+DESCRIPTION="provides an environment for testing programs and Objective Caml modules"
+HOMEPAGE="http://fort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="dev-lang/ocaml:="
+RDEPEND="${DEPEND}"
+DOCS=( README )
+
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4' && epatch "${FILESDIR}/${P}-ocaml4.patch"
+ sed -i -e "s:\$(BINDIR):\$(DESTDIR)&:"\
+ -e "s:\$(LIBDIR):\$(DESTDIR)&:" Makefile || die
+}
+
+src_configure() {
+ ./configure --bindir /usr/bin --libdir /usr/$(get_libdir)/ocaml || die
+}
diff --git a/dev-ml/fort/metadata.xml b/dev-ml/fort/metadata.xml
new file mode 100644
index 000000000000..a6c4a6fd4a04
--- /dev/null
+++ b/dev-ml/fort/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <longdescription>
+ FORT (Framework for Ocaml Regression Testing) provides
+ an environment for testing programs and Objective Caml modules.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">fort</remote-id>
+ </upstream>
+</pkgmetadata>