summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-19 09:43:41 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-19 09:44:43 +0100
commit253f71555e134b27d21a2db997f979f84253d1a2 (patch)
treec86b65c8c7fdfcc238edb24f1d650dd0d20ed6a9 /dev-ml/camlp5/camlp5-8.00.05-r1.ebuild
parentmedia-sound/gpodder: bump to 3.11.1 (diff)
downloadgentoo-253f71555e134b27d21a2db997f979f84253d1a2.tar.gz
gentoo-253f71555e134b27d21a2db997f979f84253d1a2.tar.bz2
gentoo-253f71555e134b27d21a2db997f979f84253d1a2.zip
dev-ml/camlp5: fix deps
Closes: https://bugs.gentoo.org/895350 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/camlp5/camlp5-8.00.05-r1.ebuild')
-rw-r--r--dev-ml/camlp5/camlp5-8.00.05-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/camlp5/camlp5-8.00.05-r1.ebuild b/dev-ml/camlp5/camlp5-8.00.05-r1.ebuild
new file mode 100644
index 000000000000..adb4094a4b81
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-8.00.05-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib vcs-clean
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc +ocamlopt"
+
+RDEPEND="
+ dev-ml/camlp-streams:=
+ dev-ml/rresult:=
+ dev-ml/bos:=
+ dev-ml/pcre-ocaml:=
+"
+
+src_prepare() {
+ egit_clean
+ default
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile() {
+ ulimit -s 11530000
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_test() {
+ emake bootstrap
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ dodoc -r doc/*
+ dodoc CHANGES DEVEL ICHANGES README.md UPGRADING MODE
+}