summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/async
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/async')
-rw-r--r--dev-ml/async/Manifest3
-rw-r--r--dev-ml/async/async-112.17.00.ebuild39
-rw-r--r--dev-ml/async/async-112.24.00.ebuild39
-rw-r--r--dev-ml/async/async-112.35.00.ebuild39
-rw-r--r--dev-ml/async/metadata.xml5
5 files changed, 125 insertions, 0 deletions
diff --git a/dev-ml/async/Manifest b/dev-ml/async/Manifest
new file mode 100644
index 000000000000..795447569e9a
--- /dev/null
+++ b/dev-ml/async/Manifest
@@ -0,0 +1,3 @@
+DIST async-112.17.00.tar.gz 82486 SHA256 2fa90908a87d4c12d9691a91da48b4c2e5484f770b24362618d97f111baae993 SHA512 3778f28f8ce88e32e72198ca0fd66a4727a12975f1ef6b6ed0ed09a06838d3ffc9b0004801d88b37194d428c61960be8ce369f1ccf14a6c7e556858b81aebfa5 WHIRLPOOL ec148889b63fcd3622581b2c3885e3b40f20f8d478c062810009454ae14ba82f546976d746b1388e017a43486ffc7c577c9b155b493bdac7f41c680fb5d4db43
+DIST async-112.24.tar.gz 82542 SHA256 ecc4ca939ab098e689332921b110dbaacd06d9f8d8bf697023dfff3ca37dc1e9 SHA512 985e70117c057d4117ef64acdbf6bf4ac8b08c0910b2bacd879ad2646a1b730d7071bdfca4b6fc71a3995a629833cc1b092bc0f7176d34f477081a6827bd02ef WHIRLPOOL a450fc78c9ea4bdf85612ca871a34ce0682d8d7b535cb7cc52cb93407ae1130d563a6566fb2e5c8350e073e2555b5df57c99ae4d1d4afcabcb0d32d7b969f36e
+DIST async-112.35.00.tar.gz 88263 SHA256 95228894bba807f1c3537530b8008d9c91a58708936d1f5c2101561b16125d85 SHA512 585585eee879d5f2f67ca2dbac520bc417deed2f867a870fa8d2d05da943b269f440983f983353f45c408998c8b5535c5a3b81ed0035d673bd656c416f96bf0b WHIRLPOOL 9dc8f92f65431b25fc7e322be2be4cb85473b55ec4ca8e2b5ee5f7b1dd0d4e6050cc78fe8017ff351b5bfb849f3d686e9fdd4c277ffe9c2adfbc90972fdf9aab
diff --git a/dev-ml/async/async-112.17.00.ebuild b/dev-ml/async/async-112.17.00.ebuild
new file mode 100644
index 000000000000..8598a7657320
--- /dev/null
+++ b/dev-ml/async/async-112.17.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench dev-ml/pa_ounit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/async/async-112.24.00.ebuild b/dev-ml/async/async-112.24.00.ebuild
new file mode 100644
index 000000000000..b468ae8413d6
--- /dev/null
+++ b/dev-ml/async/async-112.24.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P%.*}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench dev-ml/pa_ounit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/async/async-112.35.00.ebuild b/dev-ml/async/async-112.35.00.ebuild
new file mode 100644
index 000000000000..8598a7657320
--- /dev/null
+++ b/dev-ml/async/async-112.35.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench dev-ml/pa_ounit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/async/metadata.xml b/dev-ml/async/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/async/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>