summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-05-05 18:15:17 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-05-05 18:15:17 +0200
commit3a6641015ccb1e62a7e04860f097ae23532d8f76 (patch)
treed3f713c2ece6a858f0a23c417e0a758c14c4ebbf /dev-lua
parentdev-lua/luasocket: drop 3.0_rc1_p20200328-r103 (diff)
downloadgentoo-3a6641015ccb1e62a7e04860f097ae23532d8f76.tar.gz
gentoo-3a6641015ccb1e62a7e04860f097ae23532d8f76.tar.bz2
gentoo-3a6641015ccb1e62a7e04860f097ae23532d8f76.zip
dev-lua/luaexpat: drop 1.3.0-r1, 1.4.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaexpat/Manifest2
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.0-r1.ebuild74
-rw-r--r--dev-lua/luaexpat/luaexpat-1.4.0.ebuild73
3 files changed, 0 insertions, 149 deletions
diff --git a/dev-lua/luaexpat/Manifest b/dev-lua/luaexpat/Manifest
index 255c58b4c929..a08194314495 100644
--- a/dev-lua/luaexpat/Manifest
+++ b/dev-lua/luaexpat/Manifest
@@ -1,3 +1 @@
-DIST luaexpat-1.3.0.tar.gz 29567 BLAKE2B 176cb107e6047b15338ff45751af82389920e4210d40bd0b4400e549130a4983c843f7a64bb7b2fba37e36eb592e850d06efe196f8e837e79e50c8d135dbe763 SHA512 91884653310e2dc89ade6d1653875ac8607640a21853d3ccb1fd0f833812e41981fad5c40101732ec249104d2c50c9a332208d1e44423b8428065a223c60b4ae
-DIST luaexpat-1.4.0.tar.gz 51890 BLAKE2B 6e2cda190e7b2ebe2bda64398a447155df3ccdb83f1b4ff78aead981c38cf6705f896ba31ac0d557ec55f750919b6b2b07205c533339d7aa8e0f88ee6b0991fd SHA512 ba1a98267757ec5f2464b8d5e903f69102ca991c4034939d02d871d014463a8e29815d1294edc7fa3a1c4b679c5e42fdc1a19b2a1c1654ed1f382f779a213375
DIST luaexpat-1.4.1.tar.gz 52159 BLAKE2B dd870d2d2db8bc1e399a306eff91138752f346f50ec1283a611c3ef42591e5176beab59aa96b87c772ba0320d98fc8a5907048e539cde6c14757e9a026aacc81 SHA512 fbc03287a237c13f395574ddf08a931ded0f457728b01bdc0a0533d212a0c908d74230be3c9e7f85a54ac244043cd853be3bf13d284185ad3e3ce6818d157635
diff --git a/dev-lua/luaexpat/luaexpat-1.3.0-r1.ebuild b/dev-lua/luaexpat/luaexpat-1.3.0-r1.ebuild
deleted file mode 100644
index 186869f91be1..000000000000
--- a/dev-lua/luaexpat/luaexpat-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library"
-HOMEPAGE="https://matthewwild.co.uk/projects/luaexpat/ https://code.matthewwild.co.uk/lua-expat"
-SRC_URI="https://matthewwild.co.uk/projects/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- dev-libs/expat
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "doc/us/." )
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- # Remove '-ansi' to compile with newer lua versions
- sed -e 's/-O2//g' -e 's/-ansi//g' -i Makefile || die
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INC=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CDIR=$(lua_get_cmod_dir)"
- "LUA_INC=$(lua_get_include_dir)"
- "LUA_LDIR=$(lua_get_lmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}
diff --git a/dev-lua/luaexpat/luaexpat-1.4.0.ebuild b/dev-lua/luaexpat/luaexpat-1.4.0.ebuild
deleted file mode 100644
index b0c2791bf0e6..000000000000
--- a/dev-lua/luaexpat/luaexpat-1.4.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A SAX XML parser based on the Expat library"
-HOMEPAGE="https://github.com/lunarmodules/luaexpat"
-SRC_URI="https://github.com/lunarmodules/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- dev-libs/expat
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "docs/." )
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O2//g' -i Makefile || die
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INC=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CDIR=$(lua_get_cmod_dir)"
- "LUA_INC=$(lua_get_include_dir)"
- "LUA_LDIR=$(lua_get_lmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}