summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-06-23 11:59:20 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-07-06 10:47:40 +0200
commit4a649afe454eeeddeb4b6ec651b825eff322a88a (patch)
treefa7684a6351485f0332f6193153028f44e97e0c4 /dev-lisp
parentdev-util/ebuildtester: drop 42-r2 (diff)
downloadgentoo-4a649afe454eeeddeb4b6ec651b825eff322a88a.tar.gz
gentoo-4a649afe454eeeddeb4b6ec651b825eff322a88a.tar.bz2
gentoo-4a649afe454eeeddeb4b6ec651b825eff322a88a.zip
dev-lisp/abcl: build without BSFIX, drop java-ant-2
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/37338/commits/cf3fa180a32e3ac6fd25c581c313c9ff6c8c19dc Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/abcl/abcl-1.9.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lisp/abcl/abcl-1.9.2-r1.ebuild b/dev-lisp/abcl/abcl-1.9.2-r1.ebuild
new file mode 100644
index 000000000000..4915ed2e0d82
--- /dev/null
+++ b/dev-lisp/abcl/abcl-1.9.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2
+
+DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM"
+HOMEPAGE="https://abcl.org"
+SRC_URI="https://abcl.org/releases/${PV}/abcl-src-${PV}.tar.gz"
+S="${WORKDIR}/abcl-src-${PV}"
+
+LICENSE="GPL-2-with-classpath-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND=">=dev-java/ant-1.10.14-r3:0"
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_compile() {
+ eant abcl.compile
+ eant abcl.jar
+}
+
+src_install() {
+ java-pkg_dojar dist/abcl.jar dist/abcl-contrib.jar
+ java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
+
+ einstalldocs
+}