summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-18 09:34:44 +0000
committerSam James <sam@gentoo.org>2024-11-18 09:34:44 +0000
commit8dc343529e52550ccca2eb5441cca6dace7a7042 (patch)
tree1149763b38793062f9b7ba368f130c03188efc6e /dev-libs
parentdev-lang/python: Stabilize 3.8.20_p4 sparc, #943634 (diff)
downloadgentoo-8dc343529e52550ccca2eb5441cca6dace7a7042.tar.gz
gentoo-8dc343529e52550ccca2eb5441cca6dace7a7042.tar.bz2
gentoo-8dc343529e52550ccca2eb5441cca6dace7a7042.zip
dev-libs/ffcall: add 2.5
I've dropped the slibtool patch (at least for now) because this release fixes building w/ C23 which is more important at the moment. Bug: https://bugs.gentoo.org/776976 Bug: https://bugs.gentoo.org/829663 Closes: https://bugs.gentoo.org/879795 Closes: https://bugs.gentoo.org/943743 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ffcall/Manifest1
-rw-r--r--dev-libs/ffcall/ffcall-2.5.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/ffcall/Manifest b/dev-libs/ffcall/Manifest
index 956d5f041533..1d17452042f3 100644
--- a/dev-libs/ffcall/Manifest
+++ b/dev-libs/ffcall/Manifest
@@ -1 +1,2 @@
DIST libffcall-2.4.tar.gz 1253767 BLAKE2B 669bf556f082b533eb7d71ebc6fadeac464b1a6054ac8078c9315678929bcfb8ad4b7376b345bcfbb5d2caf9d45179012d4bb5a08ad675f475f58570ae96b7ae SHA512 c9451662764a888e3be21499c29673bfb0e1df4915814da3506db5d395a2b00ea2f0c08d1c9dffebf030179f9347794876ec6ec9e6710b4fc70fd760960335e6
+DIST libffcall-2.5.tar.gz 1451999 BLAKE2B 552a0a33bbed91380ced4bdb0f87f38be0a531e729b9530d80dd777ce93b4fe3515a984c2da0221e0110756fbbc099d666b1fed6f5cfacfccbedda7f97e58054 SHA512 5e5b1c34b9e66bde00e1deea464099ef09e439070e8180c04f2520442933e369e76632346ae59a5720356128787e88255bd75764736ac9b5334a592eb6cf5878
diff --git a/dev-libs/ffcall/ffcall-2.5.ebuild b/dev-libs/ffcall/ffcall-2.5.ebuild
new file mode 100644
index 000000000000..7f9d8f6bfae9
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-2.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool
+
+MY_PV="libffcall-${PV}"
+
+DESCRIPTION="Build foreign function call interfaces in embedded interpreter"
+HOMEPAGE="https://www.gnu.org/software/libffcall/"
+SRC_URI="mirror://gnu/libffcall/${MY_PV}.tar.gz"
+S="${WORKDIR}"/${MY_PV}
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+src_prepare() {
+ # The build system is a strange mix of autogenerated
+ # files and manual tweaks on top. Uses $CFLAGS / $LDFLAGS randomly.
+ # We are adding them consistently here and a bit over the top:
+ # bugs: #334581
+ local mfi
+ for mfi in {,*/,*/*/,}Makefile.in ; do
+ einfo "Patching '${mfi}'"
+ # usually uses only assembler here, but -march=
+ # and -Wa, are a must to pass here.
+ sed -e 's/$(CC) /&$(CFLAGS) /g' \
+ -i "${mfi}" || die
+ done
+
+ default
+ elibtoolize
+}
+
+src_configure() {
+ append-flags -fPIC
+
+ # Doc goes in datadir
+ econf \
+ --datadir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dodoc NEWS README
+ dodir /usr/share/man
+
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}