summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-08-11 14:15:56 -0400
committerMike Gilbert <floppym@gentoo.org>2021-08-11 14:15:56 -0400
commit4adb495757c67c5e9ee168264dfe38e66fedf6fb (patch)
tree101202c508f9aa133d4ee8e5852ccb6fb2d7de48 /dev-libs
parentsys-fs/udev: check if /dev is writable before running tests (diff)
downloadgentoo-4adb495757c67c5e9ee168264dfe38e66fedf6fb.tar.gz
gentoo-4adb495757c67c5e9ee168264dfe38e66fedf6fb.tar.bz2
gentoo-4adb495757c67c5e9ee168264dfe38e66fedf6fb.zip
dev-libs/openssl: replace "has test ${FEATURES}" with "use test"
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/openssl-1.1.1k-r1.ebuild2
-rw-r--r--dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild2
-rw-r--r--dev-libs/openssl/openssl-3.0.0_beta2.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-libs/openssl/openssl-1.1.1k-r1.ebuild b/dev-libs/openssl/openssl-1.1.1k-r1.ebuild
index d212bef1be76..5b98e5cde559 100644
--- a/dev-libs/openssl/openssl-1.1.1k-r1.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1k-r1.ebuild
@@ -63,7 +63,7 @@ pkg_setup() {
[[ ${MERGE_TYPE} == binary ]] && return
# must check in pkg_setup; sysctl don't work with userpriv!
- if has test ${FEATURES} && use sctp; then
+ if use test && use sctp; then
# test_ssl_new will fail with "Ensure SCTP AUTH chunks are enabled in kernel"
# if sctp.auth_enable is not enabled.
local sctp_auth_status=$(sysctl -n net.sctp.auth_enable 2>/dev/null)
diff --git a/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild b/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild
index f07fa0d1b072..d434698778c8 100644
--- a/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild
+++ b/dev-libs/openssl/openssl-3.0.0_beta1-r1.ebuild
@@ -68,7 +68,7 @@ pkg_setup() {
[[ ${MERGE_TYPE} == binary ]] && return
# must check in pkg_setup; sysctl don't work with userpriv!
- if has test ${FEATURES} && use sctp ; then
+ if use test && use sctp ; then
# test_ssl_new will fail with "Ensure SCTP AUTH chunks are enabled in kernel"
# if sctp.auth_enable is not enabled.
local sctp_auth_status=$(sysctl -n net.sctp.auth_enable 2>/dev/null)
diff --git a/dev-libs/openssl/openssl-3.0.0_beta2.ebuild b/dev-libs/openssl/openssl-3.0.0_beta2.ebuild
index f07fa0d1b072..d434698778c8 100644
--- a/dev-libs/openssl/openssl-3.0.0_beta2.ebuild
+++ b/dev-libs/openssl/openssl-3.0.0_beta2.ebuild
@@ -68,7 +68,7 @@ pkg_setup() {
[[ ${MERGE_TYPE} == binary ]] && return
# must check in pkg_setup; sysctl don't work with userpriv!
- if has test ${FEATURES} && use sctp ; then
+ if use test && use sctp ; then
# test_ssl_new will fail with "Ensure SCTP AUTH chunks are enabled in kernel"
# if sctp.auth_enable is not enabled.
local sctp_auth_status=$(sysctl -n net.sctp.auth_enable 2>/dev/null)