summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-03-10 19:01:02 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-03-10 19:01:02 +0100
commit39b0f54b58af731a905105021158bdc6210b072b (patch)
tree5077d26f1d76a24384aa52a834e7be2e634599bb /dev-libs/wayland-protocols
parentsci-mathematics/Macaulay2: add ~arm, bug #573944 (diff)
downloadgentoo-39b0f54b58af731a905105021158bdc6210b072b.tar.gz
gentoo-39b0f54b58af731a905105021158bdc6210b072b.tar.bz2
gentoo-39b0f54b58af731a905105021158bdc6210b072b.zip
dev-libs/wayland-protocols: new ebuild, required by dev-libs/weston-1.10
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/metadata.xml8
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.3.ebuild41
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild41
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
new file mode 100644
index 000000000000..03232adae8ce
--- /dev/null
+++ b/dev-libs/wayland-protocols/Manifest
@@ -0,0 +1 @@
+DIST wayland-protocols-1.3.tar.xz 101684 SHA256 6bcd0633fdf9225ef1c7d2831f542e947f7d79811c79fc37f57b2e5375ded82f SHA512 8e407bce93e595ebb7c6a8c7542d4db81d352821c63f41ac75d27f6d52e81e18e0a9a7d4b18460e446c4201931e42a98c0cd214015f154363099eda5747cd738 WHIRLPOOL 73d5c04cb987d0632fe0cc950cd8bf132f9427bd70a65777027148ada2ede0347b336f7faf6e6455171c1a5b2829835edceca15cbbbaf95b99223976279757a9
diff --git a/dev-libs/wayland-protocols/metadata.xml b/dev-libs/wayland-protocols/metadata.xml
new file mode 100644
index 000000000000..e943b72b8a48
--- /dev/null
+++ b/dev-libs/wayland-protocols/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.3.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.3.ebuild
new file mode 100644
index 000000000000..ec9062fc007d
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-multilib_src_test
+}
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
new file mode 100644
index 000000000000..ec9062fc007d
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-multilib_src_test
+}