summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-03-18 18:46:10 +0100
committerSebastian Pipping <sping@gentoo.org>2021-03-18 18:51:42 +0100
commit665ce4aca4c111011407b42293a86faa051dd777 (patch)
tree9d78e979bc574d20f3a3687e3c4967e61a520dd1 /dev-libs/uriparser
parentdev-db/pg_activity: version bump to 2.1.3 - enable tests (diff)
downloadgentoo-665ce4aca4c111011407b42293a86faa051dd777.tar.gz
gentoo-665ce4aca4c111011407b42293a86faa051dd777.tar.bz2
gentoo-665ce4aca4c111011407b42293a86faa051dd777.zip
dev-libs/uriparser: 0.9.5 + QA fixes
Closes: https://bugs.gentoo.org/773430 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.17, Repoman-3.0.2
Diffstat (limited to 'dev-libs/uriparser')
-rw-r--r--dev-libs/uriparser/Manifest1
-rw-r--r--dev-libs/uriparser/uriparser-0.9.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/uriparser/Manifest b/dev-libs/uriparser/Manifest
index a0e9a59a9916..6451abdb82d0 100644
--- a/dev-libs/uriparser/Manifest
+++ b/dev-libs/uriparser/Manifest
@@ -1 +1,2 @@
DIST uriparser-0.9.4.tar.bz2 174551 BLAKE2B b95f270685757052fca02fae0a029f08de8bc14bea733bd56e62f0bcdc6592f015453ed38c87171cea9054618328dc94a512ff816519f70594653451f751c4f8 SHA512 c5e671ce2589aacd2c562e66facbee9e1cad3101e840f40b7ebdb917fa669e0c3ae7ed75623692f601655c0b82c10bcfe3086ad628beac8f965e613228e67ecd
+DIST uriparser-0.9.5.tar.bz2 176501 BLAKE2B 5ec3d993e60c62f2478e4012354cf82f2e4155ea1a69e9a3d6611d1765fe0f3b8ba5382c928852a5fd215f51ebb0688c9d713e9f1208f18f5ce2d8b8f0fb1dca SHA512 44d36a33565b7724d721e2b5e689530227bc87e609ee78f1d23e7353480191313b1b91039c7a046566d14b83eb320c97d75e74c8ef4841e1b9c8559c3feddb34
diff --git a/dev-libs/uriparser/uriparser-0.9.5.ebuild b/dev-libs/uriparser/uriparser-0.9.5.ebuild
new file mode 100644
index 000000000000..9b571c508ab7
--- /dev/null
+++ b/dev-libs/uriparser/uriparser-0.9.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Strictly RFC 3986 compliant URI parsing library in C"
+HOMEPAGE="https://uriparser.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="+doc qt5 test unicode" # +doc to address warning RequiredUseDefaults
+
+REQUIRED_USE="qt5? ( doc ) test? ( unicode )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( >=dev-cpp/gtest-1.8.1 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.5.8
+ qt5? ( dev-qt/qthelp:5 )
+ )
+"
+
+DOCS=( AUTHORS ChangeLog THANKS )
+
+src_configure() {
+ local mycmakeargs=(
+ -DURIPARSER_BUILD_CHAR=ON
+ -DURIPARSER_BUILD_DOCS=$(usex doc ON OFF)
+ -DURIPARSER_BUILD_TESTS=$(usex test ON OFF)
+ -DURIPARSER_BUILD_TOOLS=ON
+ -DURIPARSER_BUILD_WCHAR_T=$(usex unicode ON OFF)
+
+ # The usex wrapper is here to address this warning:
+ # One or more CMake variables were not used by the project:
+ # CMAKE_DISABLE_FIND_PACKAGE_Qt5Help
+ $(usex doc "$(cmake_use_find_package qt5 Qt5Help)")
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc && use qt5; then
+ dodoc "${BUILD_DIR}"/doc/*.qch
+ docompress -x /usr/share/doc/${PF}/${P}.qch
+ fi
+}