summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-10-30 12:12:43 +0100
committerDavid Seifert <soap@gentoo.org>2022-10-30 12:12:43 +0100
commit0fd9dc449c6e0f8a7224ee6e1a67b94e23e59b79 (patch)
treeb8e0ad764056234eb984791cb63e5ce88527fbef /dev-libs/rapidjson
parentdev-libs/protobuf/files: [QA] use git-format-patch style patches (diff)
downloadgentoo-0fd9dc449c6e0f8a7224ee6e1a67b94e23e59b79.tar.gz
gentoo-0fd9dc449c6e0f8a7224ee6e1a67b94e23e59b79.tar.bz2
gentoo-0fd9dc449c6e0f8a7224ee6e1a67b94e23e59b79.zip
dev-libs/rapidjson/files: [QA] use git-format-patch style patches
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/rapidjson')
-rw-r--r--dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch8
-rw-r--r--dev-libs/rapidjson/files/rapidjson-1.1.0-valgrind_optional.patch4
-rw-r--r--dev-libs/rapidjson/files/rapidjson-1.1.1-valgrind_optional.patch4
3 files changed, 8 insertions, 8 deletions
diff --git a/dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch b/dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch
index bdc720e8cf86..a952a076dc47 100644
--- a/dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch
+++ b/dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch
@@ -1,5 +1,5 @@
---- /CMakeModules/FindGTestSrc.cmake
-+++ /CMakeModules/FindGTestSrc.cmake
+--- a/CMakeModules/FindGTestSrc.cmake
++++ b/CMakeModules/FindGTestSrc.cmake
@@ -1,30 +1,9 @@
-
-SET(GTEST_SEARCH_PATH
@@ -32,8 +32,8 @@
find_package_handle_standard_args(GTestSrc DEFAULT_MSG
- GTEST_SOURCE_DIR
GTEST_INCLUDE_DIR)
---- /test/CMakeLists.txt
-+++ /test/CMakeLists.txt
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
@@ -8,7 +8,6 @@
set(gtest_force_shared_crt ON)
endif()
diff --git a/dev-libs/rapidjson/files/rapidjson-1.1.0-valgrind_optional.patch b/dev-libs/rapidjson/files/rapidjson-1.1.0-valgrind_optional.patch
index 071a3d2392df..772eabe8c6df 100644
--- a/dev-libs/rapidjson/files/rapidjson-1.1.0-valgrind_optional.patch
+++ b/dev-libs/rapidjson/files/rapidjson-1.1.0-valgrind_optional.patch
@@ -1,7 +1,7 @@
https://github.com/Tencent/rapidjson/issues/1808
---- /test/unittest/CMakeLists.txt
-+++ /test/unittest/CMakeLists.txt
+--- a/test/unittest/CMakeLists.txt
++++ b/test/unittest/CMakeLists.txt
@@ -77,12 +77,15 @@
COMMAND ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/unittest
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/bin)
diff --git a/dev-libs/rapidjson/files/rapidjson-1.1.1-valgrind_optional.patch b/dev-libs/rapidjson/files/rapidjson-1.1.1-valgrind_optional.patch
index b40a39fb13db..e05c28000875 100644
--- a/dev-libs/rapidjson/files/rapidjson-1.1.1-valgrind_optional.patch
+++ b/dev-libs/rapidjson/files/rapidjson-1.1.1-valgrind_optional.patch
@@ -1,7 +1,7 @@
https://github.com/Tencent/rapidjson/issues/1808
---- /test/unittest/CMakeLists.txt
-+++ /test/unittest/CMakeLists.txt
+--- a/test/unittest/CMakeLists.txt
++++ b/test/unittest/CMakeLists.txt
@@ -78,12 +78,15 @@
COMMAND ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/unittest
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/bin)